Bug 520214

Summary: Build mod_exec for proftpd
Product: [Fedora] Fedora EPEL Reporter: Ray Van Dolson <rayvd>
Component: proftpdAssignee: Matthias Saou <matthias>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: el5CC: matthias, paul
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.3.2a-5.el5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-22 22:25:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ray Van Dolson 2009-08-28 23:25:21 UTC
I would like to see mod_exec[1][2] built as a subpackage (proftpd-exec).  Specifically would like to see this for EPEL 4/5, but obviously adding to the other branches would be fine as well.

Any concerns?  Obviously not wanting to add this to the default package -- definitely should be optional.

Happy to prepare a patch and/or commit necessary changes if needed.

[1] http://www.castaglia.org/proftpd/modules/mod_exec.html
[2] http://www.castaglia.org/proftpd/modules/proftpd-mod-exec-0.9.6.tar.gz

Comment 1 Paul Howarth 2009-09-02 09:39:33 UTC
I'll build this in the main package as a DSO that needs manually loading if you want this functionality. I don't think there's any need to split off a subpackage for it since it's a small module and adds no extra dependencies.

Curious as to why you want it though, given that even the upstream author thinks there are better alternatives and it's unlikely to work with DefaultRoot, which we enable by default.

Comment 2 Fedora Update System 2009-09-02 11:05:47 UTC
proftpd-1.3.2a-4.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/proftpd-1.3.2a-4.el5

Comment 3 Ray Van Dolson 2009-09-02 11:31:18 UTC
(In reply to comment #1)
> I'll build this in the main package as a DSO that needs manually loading if you
> want this functionality. I don't think there's any need to split off a
> subpackage for it since it's a small module and adds no extra dependencies.
> 
> Curious as to why you want it though, given that even the upstream author
> thinks there are better alternatives and it's unlikely to work with
> DefaultRoot, which we enable by default.  

I wanted to use it for some simple upload notification.  An alternative sounds like something worth looking into though.  I was wanting to avoid doing something like an xferlog watcher...

I'll see what else is out there -- do you have a pointer on upstream suggestions?   Didn't stumble across anything in an initial search.

Thanks.

Comment 4 Paul Howarth 2009-09-02 12:01:52 UTC
Upstream suggests logging to a FIFO and then having something sat on the end of the FIFO executing commands as needed:

http://www.castaglia.org/proftpd/modules/mod_exec.html#Usage

Comment 5 Fedora Update System 2009-09-02 20:54:21 UTC
proftpd-1.3.2a-4.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update proftpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0382

Comment 6 Paul Howarth 2009-09-07 13:09:45 UTC
I think upstream was being a bit coy about this module: it's included in 1.3.3rc1:

http://www.proftpd.org/docs/RELEASE_NOTES-1.3.3rc1

Any feedback on the update?

Comment 7 Fedora Update System 2009-09-07 15:13:02 UTC
proftpd-1.3.2a-5.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/proftpd-1.3.2a-5.el5

Comment 8 Fedora Update System 2009-09-08 22:58:51 UTC
proftpd-1.3.2a-5.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update proftpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0397

Comment 9 Ray Van Dolson 2009-09-10 15:57:36 UTC
(In reply to comment #6)
> I think upstream was being a bit coy about this module: it's included in
> 1.3.3rc1:
> 
> http://www.proftpd.org/docs/RELEASE_NOTES-1.3.3rc1
> 
> Any feedback on the update?  

Interesting... I'm still thinking your suggestion of using a FIFO may be the most secure way to go, but in the interim I am able to use this.

Thanks much for the quick response!

Comment 10 Fedora Update System 2009-09-22 22:25:22 UTC
proftpd-1.3.2a-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.