Bug 520230

Summary: pa_stream_writable_size() failed: Connection terminated
Product: [Fedora] Fedora Reporter: ambrish dhaka <ambijat>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: bnocera, lkundrak, lpoetter, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-07 11:57:12 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
text of grep on pulseaudio none

Description ambrish dhaka 2009-08-29 07:07:36 EDT
pa_stream_writable_size() failed: Connection terminated


This comment appears in all sound and video players. All mp3, mpg and other format get stuck in the middle of the playing.
The issue seems to be in pulseaudio and other soundcard software.
I guess!
Comment 1 Lennart Poettering 2009-09-03 10:52:36 EDT
PA probably terminated. Most likely to a snd_pcm_delay()/snd_pcm_avail() related driver problem.

Please grep syslog for all pulseaudio related output and paste it here.
Comment 2 ambrish dhaka 2009-09-05 15:33:35 EDT
Please see if the command is ok. I see there is almost endless details coming out of it, all of which cannot be pasted. I have pasted some major sections.
thanks!
Ambrish Dhaka



[root@JNU-7465RTS adhaka]# grep pulseaudio /var/log/messages | more
Aug 30 20:10:04 JNU-7465RTS pulseaudio[1935]: alsa-sink.c: Device hw:1 is modem, refusing further initial
ization.
Aug 30 20:10:04 JNU-7465RTS pulseaudio[1935]: alsa-source.c: Device hw:1 is modem, refusing further initi
alization.
Aug 30 20:10:04 JNU-7465RTS dbus: Rejected send message, 2 matched rules; type="method_call", sender=":1.
30" (uid=42 pid=1935 comm="/usr/bin/pulseaudio --start --log-target=syslog ") interface="org.bluez.Manage
r" member="ListAdapters" error name="(unset)" requested_reply=0 destination="org.bluez" (uid=0 pid=1542 c
omm="/usr/sbin/bluetoothd "))
Aug 30 20:10:04 JNU-7465RTS pulseaudio[1935]: bluetooth-util.c: Error from ListAdapters reply: org.freede
sktop.DBus.Error.AccessDenied
Aug 30 20:10:18 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Device hw:1 is modem, refusing further initial
ization.
Aug 30 20:10:18 JNU-7465RTS pulseaudio[2087]: alsa-source.c: Device hw:1 is modem, refusing further initi
alization.
Aug 30 20:10:21 JNU-7465RTS pulseaudio[2153]: pid.c: Daemon already running.
Aug 30 21:36:21 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing minimal latency to 1.00 ms
Aug 30 21:36:24 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing minimal latency to 2.00 ms
Aug 30 21:36:24 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing minimal latency to 4.00 ms
Aug 30 21:36:24 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing minimal latency to 8.00 ms
Aug 30 21:36:27 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing minimal latency to 16.00 ms
Aug 30 21:36:36 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing wakeup watermark to 8.00 ms
Aug 30 21:37:06 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing minimal latency to 26.00 ms
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-sink.c: Increasing wakeup watermark to 16.00 ms
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: snd_pcm_avail() returned a value that is excep
tionally large: 4294963812 bytes (22369603 ms).
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Most likely this is a bug in the ALSA driver '
snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: snd_pcm_dump():
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subd
evice 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Its setup is:
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   stream       : PLAYBACK
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   format       : S16_LE
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   subformat    : STD
--More--
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Its setup is:
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   stream       : PLAYBACK
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   format       : S16_LE
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   subformat    : STD
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   channels     : 2
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   rate         : 48000
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   exact rate   : 48000 (48000/1)
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   msbits       : 16
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   buffer_size  : 16384
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_size  : 16384
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_time  : 341333
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_step  : 1
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   avail_min    : 16384
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_event : 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   start_threshold  : -1
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   stop_threshold   : 1073741824
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   silence_threshold: 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   silence_size : 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   boundary     : 1073741824
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   appl_ptr     : 3294059
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   hw_ptr       : 3276804
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: snd_pcm_delay() returned a value that is excep
tionally large: 366980 bytes (1911 ms).
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Most likely this is a bug in the ALSA driver '
snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: snd_pcm_dump():
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subd
evice 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c: Its setup is:
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   stream       : PLAYBACK

Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   stream       : PLAYBACK
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   format       : S16_LE
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   subformat    : STD
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   channels     : 2
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   rate         : 48000
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   exact rate   : 48000 (48000/1)
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   msbits       : 16
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   buffer_size  : 16384
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_size  : 16384
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_time  : 341333
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_step  : 1
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   avail_min    : 16384
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   period_event : 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   start_threshold  : -1
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   stop_threshold   : 1073741824
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   silence_threshold: 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   silence_size : 0
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   boundary     : 1073741824
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   appl_ptr     : 3368939
Aug 30 21:37:29 JNU-7465RTS pulseaudio[2087]: alsa-util.c:   hw_ptr       : 3277194
Aug 30 21:37:34 JNU-7465RTS pulseaudio[2087]: ratelimit.c: 2720 events suppressed
Aug 30 21:37:39 JNU-7465RTS pulseaudio[2087]: ratelimit.c: 2833 events suppressed
Aug 30 21:37:42 JNU-7465RTS pulseaudio[2087]: cpulimit.c: Received request to terminate due to CPU overlo
ad.
Aug 30 21:49:38 JNU-7465RTS pulseaudio[3731]: polkit.c: Cannot set UID on session object.
Aug 30 21:49:38 JNU-7465RTS pulseaudio[3734]: alsa-sink.c: Device hw:1 is modem, refusing further initial
ization.
Aug 30 21:49:38 JNU-7465RTS pulseaudio[3734]: alsa-source.c: Device hw:1 is modem, refusing further initi
alization.
Aug 30 22:10:05 JNU-7465RTS pulseaudio[3734]: alsa-sink.c: Increasing minimal latency to 1.00 ms
Aug 30 22:10:05 JNU-7465RTS pulseaudio[3734]: alsa-sink.c: Increasing minimal latency to 2.00 ms
--More--
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: snd_pcm_avail() returned a value that is excep
tionally large: 4294947856 bytes (22369520 ms).
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: Most likely this is a bug in the ALSA driver '
snd_intel8x0'. Please report this issue to the ALSA developers.
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: snd_pcm_dump():
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subd
evice 0
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: Its setup is:
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   stream       : PLAYBACK
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   access       : MMAP_INTERLEAVED
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   format       : S16_LE
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   subformat    : STD
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   channels     : 2
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   rate         : 48000
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   exact rate   : 48000 (48000/1)
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   msbits       : 16
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   buffer_size  : 16384
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   period_size  : 16384
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   period_time  : 341333
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   tstamp_mode  : ENABLE
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   period_step  : 1
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   avail_min    : 16384
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   period_event : 0
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c:   start_threshold  : -1
--More--
Comment 3 ambrish dhaka 2009-09-05 15:38:24 EDT
Created attachment 359880 [details]
text of grep on pulseaudio
Comment 4 ambrish dhaka 2009-09-05 15:40:36 EDT
See there is also some reference to ALSAdrivers as I quote from above text.

Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: snd_pcm_avail()
returned a value that is excep
tionally large: 4294947856 bytes (22369520 ms).
Aug 30 22:11:35 JNU-7465RTS pulseaudio[3734]: alsa-util.c: Most likely this is
a bug in the ALSA driver '
snd_intel8x0'. Please report this issue to the ALSA developers.


I hope it helps. 

Ambrish
Comment 5 Lennart Poettering 2009-09-07 11:57:12 EDT

*** This bug has been marked as a duplicate of bug 506075 ***