Bug 520965

Summary: Consider renaming PackageKit-debuginfo-install to PackageKit-debug-install
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: PackageKitAssignee: Richard Hughes <richard>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dcantrell, mclasen, rhughes, richard, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-03 12:44:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jesse Keating 2009-09-02 22:45:39 UTC
The compose tools get tripped up on the name of this and think that "PackageKit-debuginfo-install" is actually a debuginfo package, and it gets put in the debuginfo repo.  This is because we have some packages with names like "foo-debuginfo-common" and then various sub-debuginfo packages thereof, so just searching for packages that end in -debuginfo won't work.  We could work harder on a regex to avoid the PackageKit package, but I wanted to start with a request to rename the subpackage.

Comment 1 Richard Hughes 2009-09-03 06:58:01 UTC
Sure, fine with me. If you rename the subpackage in PackageKit.spec, just ensure you obsolete the old PackageKit-debuginfo-install subpackage too.

Comment 2 Matthias Clasen 2009-09-03 12:44:40 UTC
Ok, I've done it.