Bug 521045

Summary: setroubleshoot: SELinux is preventing ldconfig "read" access on /usr/share/gajim/src/gtkexcepthook.py.
Product: [Fedora] Fedora Reporter: Matěj Cepl <mcepl>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: drepper, dwalsh, mcepl, mcepl, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:8e026d3d63f650b5588f41f280b7fc17f8c4c499acc1bd6b1be2fb2945a9011a
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-03 10:59:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matěj Cepl 2009-09-03 10:07:18 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing ldconfig "read" access on
/usr/share/gajim/src/gtkexcepthook.py.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by ldconfig. It is not expected that this access
is required by ldconfig and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                unconfined_u:unconfined_r:ldconfig_t:s0-s0:c0.c102
                              3
Kontext cíle                 system_u:object_r:usr_t:s0
Objekty cíle                 /usr/share/gajim/src/gtkexcepthook.py [ file ]
Zdroj                         ldconfig
Cesta zdroje                  /sbin/ldconfig
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          glibc-2.10.90-18
RPM balíčky cíle           gajim-0.13-0.1.20090901hg.1.fc12
RPM politiky                  selinux-policy-3.6.30-1.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.190.rc8.fc12.x86_64 #1 SMP
                              Fri Aug 28 18:51:58 EDT 2009 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               Čt 3. září 2009, 11:57:51 CEST
Naposledy viděno             Čt 3. září 2009, 11:57:51 CEST
Místní ID                   6fa9ce84-6d00-4951-8fbf-28a086c82431
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1251971871.629:84): avc:  denied  { read } for  pid=4683 comm="ldconfig" path="/usr/share/gajim/src/gtkexcepthook.py" dev=dm-1 ino=46985 scontext=unconfined_u:unconfined_r:ldconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:usr_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1251971871.629:84): arch=c000003e syscall=59 success=yes exit=0 a0=f66a50 a1=f66b50 a2=f64a70 a3=7ffff22e1410 items=0 ppid=4682 pid=4683 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts0 ses=1 comm="ldconfig" exe="/sbin/ldconfig" subj=unconfined_u:unconfined_r:ldconfig_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= ldconfig_t ==============
allow ldconfig_t usr_t:file read;

Comment 1 Matěj Cepl 2009-09-03 10:59:46 UTC
This is probably nonsense ... using latest hg version (that's hg for mercurial).

Comment 2 Daniel Walsh 2009-09-08 10:44:54 UTC
It could be some kind of leaked file descriptor, since I doubt ldconfig is reading python files?

Comment 3 Matěj Cepl 2009-09-09 08:11:36 UTC
Possibly, why we don't have full command line in the report as well? There are too many /usr/bin/python processes on Fedora.