Bug 521189

Summary: /sbin/loader received SIGSEGV!
Product: Red Hat Enterprise Linux 5 Reporter: Alex He <ahe>
Component: anacondaAssignee: Martin Sivák <msivak>
Status: CLOSED CURRENTRELEASE QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: low    
Version: 5.4CC: atodorov, caiqian, ddumas
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 11.1.2.196 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-17 23:13:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Backtrace
none
Another SegFault screenshot, may be another bug.
none
Do not show partition selection if the device disappeared
none
vmlinuz ( testKernel )
none
initrd.img ( testKernel )
none
Driver Update Disk for test none

Description Alex He 2009-09-04 07:36:42 UTC
Description of problem: 
during the driver choosing window( ie. /dev/sda, /dev/scd0, /dev/sdb )
first detach the attached USB flash driver( /dev/sdb ). then choose /dev/sdb,
and try to load drivers from that device, then loader will segfault.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.made a USB Driver update disk, then plug the USB device to test machine. 
2.boot RHEL 5.4 CDROM with 'linux dd', then go to the driver choosing window:
     ie. would list the available  drivers contain driver updates:
                      /dev/sda
                      /dev/sdb
                      /dev/sdc0
     NOTE: in my testing case, the USB driver mapped to /dev/sdb  
3. then detach that USB flash driver. and choose /dev/sdb , then try to load
   its dirver.  

  
Actual results:
will report "/sbin/loader  received SIGSEGV!...." 

Expected results:
/sbin/loader can handle this exception.

Additional info:

Comment 1 Chris Lumens 2009-09-04 17:02:26 UTC
Please post the exact stack trace you are seeing so we have an idea what the problem is.

Comment 2 Alex He 2009-09-07 02:28:10 UTC
Created attachment 359937 [details]
Backtrace

Comment 3 Alex He 2009-09-07 02:29:46 UTC
Created attachment 359938 [details]
Another SegFault screenshot, may be another bug.

Comment 4 David Cantrell 2009-09-07 21:12:13 UTC
Backtrace data for comments #2 and #3:

0x400c83
0x504550
0x56fa15
0x504c30
0x5126bb
0x51e7b7
0x40aad8
0x402411
0x503790

/usr/src/debug/anaconda-11.1.2.195/loader2/loader.c:1363
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/loader2/driverdisk.c:291
/usr/src/debug/anaconda-11.1.2.195/loader2/loader.c:1602
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28

0x400c83
0x504550
0x51e699
0x40aad8
0x40b2c7
0x402411
0x503790
0x4001b9

/usr/src/debug/anaconda-11.1.2.195/loader2/loader.c:1363
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.1.2.195/loader2/driverdisk.c:291
/usr/src/debug/anaconda-11.1.2.195/loader2/driverdisk.c:525
/usr/src/debug/anaconda-11.1.2.195/loader2/loader.c:1602
/usr/src/debug/anaconda-11.1.2.195/stubs/unicode-lite.c:28
??:0

Comment 5 Martin Sivák 2009-11-12 11:27:12 UTC
Created attachment 369183 [details]
Do not show partition selection if the device disappeared

Comment 6 RHEL Product and Program Management 2009-11-12 11:41:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Alexander Todorov 2009-11-12 12:57:33 UTC
qa_ack+

Alex,
can you help with testing once this is fixed? It seems that you have an easy way to reproduce. 

Thanks.

Comment 8 Alex He 2009-11-12 13:24:06 UTC
OK.(In reply to comment #7)
> qa_ack+
> 
> Alex,
> can you help with testing once this is fixed? It seems that you have an easy
> way to reproduce. 

ok. can u point me where i can download the ISO for testing ?
 
thank,
--
Alex

> Thanks.

Comment 9 Martin Sivák 2009-11-12 13:41:33 UTC
There is no ISO at the moment. We have to solve one build issue first.

Comment 11 Alex He 2009-12-21 07:25:12 UTC
hi Martin,
 i just tried RHEL5.5-Server-20091215.nightly build( with Anaconda-11.1.2.198-3.x86_64.rpm ), it seems that there are regression bugs, 
since i cannot see "driver choosing window" after done all steps for reproduce.

  pls to confirm this bug.
BTW, i will attach the Driver Update Image for test.

Comment 12 Martin Sivák 2009-12-21 13:56:15 UTC
According to my tests it doesn't segfault anymore. What exatly are you seeing and want to see instead?

Comment 13 Alex He 2009-12-23 03:35:21 UTC
Created attachment 379968 [details]
vmlinuz ( testKernel )

Comment 14 Alex He 2009-12-23 03:36:37 UTC
Created attachment 379969 [details]
initrd.img ( testKernel )

Comment 15 Alex He 2009-12-23 03:37:55 UTC
Created attachment 379970 [details]
Driver Update Disk for test

Comment 17 Alex He 2009-12-23 05:52:00 UTC
(In reply to comment #12)
> According to my tests it doesn't segfault anymore. What exatly are you seeing
> and want to see instead?  

hi Martin,
  this time, verification PASSED, so this bug has been fixed.


my previous verification FAILED was caused by a new bug:
  if BIOS option "SATA Operation" is not "Legacy" mode( in other three mode: "RAID Autodect/AHCI"(default value), "RAID Autodect/ATA" and  "RAID On". ), then pluged USB driver update disk onto the test machine before boot up the test kernel and pressed "OK" button on the "Driver disk" text window, 
  then installer cannot go to next step , and got following info :

    console       useful info     
   -------------------------------------------------- 
   "CTRL+ALT+F1"  just show blue background, cannot g
   "CTRL+ALT+F3"  "INFO: no firewire controller found"
   "CTRL+ALT+F4"  "<6> sda: unknown partition table"
                  "<5>sd 0:0:0:0: Attached scsi removable disk sda"

i will create a new bug.

Comment 19 Alex He 2010-03-22 07:06:13 UTC
memorandam( Mon Mar 22 09:36:17 CST 2010 ):

-------------------------------------------------------------------------------
<lwang> ahe: ping when you get a chance?
<ahe> lwang: pong,  go ahead
<lwang> the change that martin made to bug 521189 is causing DUP not be able to work..
<lwang> ahe, we are looking at backing out the change..
<lwang> a driver disk on top of 5.5
<ahe> lwang: let me have a look at 521189
<lwang> ahe, ok
<ahe> lwang: you mean the patch for bz521189 caused a regression bug in 5.5 ?
<lwang> yes.
<lwang> ahe, when jcm tried to do a dup disk driver disc and run it on 5.5, (which we will be working on in a few weeks), failed
<lwang> ahe, anaconda team tracked down to the fix for bug 521189
<lwang> ahe, so my question is, in the bug, you mentioned that 
<lwang> you tested the martin's fix, and it worked.
<lwang> how did you test it?
<ahe> lwang: yes
<lwang> did you test it with 5.4 dup?
<ahe> yes, 5.4
<ahe> the patch works on 5.4
<lwang> ahe, he backported the fix to 5.4?
* kexin (~kexin_@dhcp-65-107.nay.redhat.com) has joined #dup
<jcm> It wasn't just that patch that caused the problem, like I said
<lwang> jcm, oh? what else caused the problem?
<jcm> The diff is bigger than just that, if you look at the delta between that bugfix (01b52e63ba390a6534cc00107941c747dcaad19a) and current, you will see other changes in the partition code
<ahe> lwang: ask Martin this question, i tested the bug by using new initrd.img&vmlinuz what have applied that patch.
<jcm> lwang: what I'm saying is, we know that the fix David has works with only a risk to 521189 in behavior, but there have been other partitioning changes in 5.5 from Martin. We don't know what will happen if we just pull out one of them.
<lwang> jcm, david's proposed change causes regression
<jcm> lwang: huh?
<lwang> jcm, see his latest update
<lwang> msivak, if you see this backlog, can you confirm if bugfix for bug 521189 is 
<lwang> https://bugzilla.redhat.com/attachment.cgi?id=369183
<lwang> msivak, thanks.
<lwang> jcm, can you help test out the anaconda with the patch backout?
<jcm> lwang: I am looking, give me 10 minutes
<lwang> jcm, ok thank you so much!
<ahe> lwang: i will test that bug on latest  RHEL5.5. 
<jcm> lwang: you available by phone now, number?
<lwang> ahe, thanks. you probably will see the problem exist again..
<lwang> jcm, 650 575 6320
<jcm> 2 mins
* yk is now known as yk_mtg
* kexin has quit (Quit: Leaving)
* yk_mtg is now known as yk
* lwang has quit (Quit: Leaving)
* yk is now known as yk_lunch
<ahe> lwang, jcm: bz521189 verification PASSED on latest RHEL5.5 ( using http://porkchop.devel.redhat.com/nightly/RHEL5.5-Server-20100321.nightly/tree-x86_64 ).
<jcm> good
<jcm> ahe: what test did you do?
<ahe> lwang, jcm:  BTW, if create USB by "dd if=dud.iso of=/dev/sdb"( /dev/sdb map the USB device ),  then cause update driver FAIL.
<jcm> yea, that's expected
<jcm> it's supposed to be a file on a regular USB stick, not made with dd
<jcm> ahe: what test did you do?
<ahe> lwang, jcm:  BTW, if create USB by "cp -vf dud.iso /media/USB/ "( USB device map to /dev/sdb, and /dev/sdb1 was mounted at media/USB  ),  then everything is OK.
<ahe> jcm: DUD test
<jcm> cool, that is fine. all as expected, thanks!
<ahe> jcm: and the bug reproducer
<jcm> I will be back later
<jcm> thanks Alex
<ahe> jcm: np :)
* yk_lunch is now known as yk
<ahe> lwang: my investigation result is : either the "regression bug" you mentioned was caused by create USB driver disk using "dd if=dud.iso of=/dev/sdb" and is *not a bug*( RHEL5 don't supported that ), or the "regression bug" is a new bug caused by other patch.
<jcm> ahe: did you test a CD install?
<ahe> jcm: no
<jcm> ahe: the regression affects CDROM installs in particular
<jcm> ahe: also, the version of anaconda in that nightly tree is old
<jcm> ahe: please include in your summary which version of anaconda you are running :)
<ahe> jcm: anaconda-11.1.2.206-1.x86_64;  AIK,  driver update phase is a part of Anaconda STAGE1, and the STAGE1 only need "initrd.img&vmlinuz" what is locate at CDROM-IMAGE:/isolinux/
<jcm> ahe: the latest version of anaconda with the fix is anaconda-11.1.2.208-1
<ahe> jcm: but we can confirm that the "regression bug" was not caused by the patch for bz521189 with anaconda-11.1.2.206-1.x86_64.
<jcm> nope
<jcm> because the regression affects CD installs
<jcm> or USB installs where the filesystem is not on a partition
<ahe> jcm: i don't think so, since kernel imgs( vmlinuz&intrd.img ) and /sbin/loader was loaded into memory in Anaconda STAGE1.
<jcm> The issue is in the partition handling code for driver disks
<ahe> jcm: pls post the latest RHEL5.5 ISO url, i will verify that bug by cd installs.
<jcm> Please try a CD driver disk, you will see what I mean
<jcm> I will attach an updated boot.iso, I do not have a full tree yet (but you can boot from the boot.iso and then use the regular image)
<jcm> rel-eng is building a new tree at the moment
<jcm> I will attach to the BZ, going to sleep soon. Goodnight and thanks :)
<ahe> jcm: no IDE-CDROM driver here,
<ahe> jcm: thanks, i will verify that bug by using USB driver disk & RHEL5.5 DVD/CD media,  good night :)

Comment 20 Alex He 2010-03-22 08:01:56 UTC
memorandam++ 
( Mon Mar 22 15:04:51 CST 2010 ):

<jcm> ahe: if you put the driver disk on a USB device without a partition, it will be similar to a CD
<jcm> just make a filesystem directly on /dev/sdb instead of /dev/sdb1
<jcm> thanks, sorry, it's late I must go :)

Comment 21 Alexander Todorov 2010-03-24 19:28:31 UTC
This will not be fixed in 5.5. Removed from anaconda advisory. Moving to 5.6.

Comment 22 RHEL Product and Program Management 2010-03-24 19:37:23 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 28 David Cantrell 2011-02-17 23:13:46 UTC
Closing per comment #27.