Bug 521302

Summary: ipa host-add and ipa host-del and integrated DNS
Product: [Retired] freeIPA Reporter: Jenny Severance <jgalipea>
Component: DocumentationAssignee: David O'Brien <daobrien>
Status: CLOSED DUPLICATE QA Contact: Chandrasekar Kannan <ckannan>
Severity: high Docs Contact:
Priority: high    
Version: 2.0CC: benl, dpal, jgalipea, rcritten, rvokal
Target Milestone: v2 releaseKeywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 646198 (view as bug list) Environment:
Last Closed: 2010-11-25 04:53:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 431022, 489811, 646198, 646217    

Description Jenny Severance 2009-09-04 16:58:22 UTC
Description of problem:
With integrated DNS the ipa host-add and ipa host-del commands should be adding and removing DNS entries respectively.  This would need to be documented.

This also affects the ipa replica installation process.  In that before creating a replica package with ipa-replica-prepare, you would need to execute ipa host-add to be able to resolve the replica otherwise when you go to copy the file to the replica, the primary will fail to resolve the replica.

Version-Release number of selected component (if applicable):
v2.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David O'Brien 2009-09-29 01:24:29 UTC
What's the status of this bug? Given the discussion on the mailing list where removal was not required and having the option to remove was being deferred, I wonder if this can be closed off.

Comment 2 Dmitri Pal 2010-02-17 14:48:03 UTC
I think the plan is still to add the host related DNS entries if "something" is configured to indicate that they should be automatically added.
Removal of the deleted systems does not sound like a right idea to me.

Comment 3 Dmitri Pal 2010-02-17 14:49:17 UTC
Please add the information for documentation when the solution is provided.

Comment 4 Jenny Severance 2010-02-23 21:01:34 UTC
I believe as it is now, when you create a replica package for a new replica, DNS entries will automatically be created.  When you remove a replica, the DNS entries will not be removed though.  -  Rob will need to confirm.

Comment 6 Rob Crittenden 2010-03-15 18:10:38 UTC
We plan to remove the SRV records on replica uninstall (LDAP, kerberos, etc) but leave the A and PTR records as an exercise for the admin. Martin is going to take care of the coding around this.

Comment 7 David O'Brien 2010-09-09 02:19:33 UTC
Is there an associated BZ that will describe how this works? This also looks like something that will fit into the Training Plan in the "Uninstallation" section.

Comment 8 David O'Brien 2010-11-25 04:53:40 UTC

*** This bug has been marked as a duplicate of bug 646198 ***