Bug 521446

Summary: setroubleshoot: SELinux is preventing the kdm from using potentially mislabeled files (.Xauthority).
Product: [Fedora] Fedora Reporter: STEVEN WARD <stevenward666>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:685ecf9ef248dc5b58c6c88f34f9336732de3103bb530f4f91655cf22f1b4c35
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-06 19:39:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description STEVEN WARD 2009-09-05 22:04:09 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the kdm from using potentially mislabeled files
(.Xauthority).

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux has denied kdm access to potentially mislabeled file(s) (.Xauthority).
This means that SELinux will not allow kdm to use these files. It is common for
users to edit files in their home directory or tmp directories and then move
(mv) them to system directories. The problem is that the files end up with the
wrong file context which confined applications are not allowed to access.

Allowing Access:

If you want kdm to access this files, you need to relabel them using restorecon
-v '.Xauthority'. You might want to relabel the entire directory using
restorecon -R -v ''.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .Xauthority [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.3.1-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-2.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-0.199.rc8.git2.fc12.i686 #1
                              SMP Wed Sep 2 21:10:11 EDT 2009 i686 athlon
Alert Count                   1
First Seen                    Sat 05 Sep 2009 08:58:50 PM BST
Last Seen                     Sat 05 Sep 2009 08:58:50 PM BST
Local ID                      48e3c06f-99db-4ce8-b232-2f2c5a2cb7e2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252180730.620:20): avc:  denied  { read } for  pid=1340 comm="kdm" name=".Xauthority" dev=dm-0 ino=8240 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252180730.620:20): arch=40000003 syscall=5 success=yes exit=7 a0=bfb6850c a1=8000 a2=1b6 a3=8065fc0 items=0 ppid=1304 pid=1340 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file read;

Comment 1 Daniel Walsh 2009-09-06 19:39:51 UTC

*** This bug has been marked as a duplicate of bug 521449 ***