Bug 521474

Summary: Fedora 12 Alpha doesn't boot on macbook pro 5,5 13"
Product: [Fedora] Fedora Reporter: Tommaso Visconti <tommaso.visconti>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 12CC: anaconda-maint-list, itamar, jlaska, kernel-maint, shekay, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-08-27 14:48:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Tommaso Visconti 2009-09-06 05:52:17 EDT
Description of problem:

After grub boot, probably when anaconda should start, only a blank black screen is diplayed. The same happens with basic video driver. ALT+F[1|2|..] doesn't work. I can only shut down with power button.

Version-Release number of selected component (if applicable): Fedora 12 alpha downloaded 05 sept. 2009

Fedora 11 boots properly.
Comment 1 Chris Lumens 2009-09-08 15:17:56 EDT
Do you mean the installer doesn't start up, or that the installed system itself doesn't start up?
Comment 2 Tommaso Visconti 2009-09-08 16:21:41 EDT
Sorry, i mean the installer. It's impossible to install the system
Comment 3 Chris Lumens 2009-09-09 10:48:11 EDT
You tried xdriver=vesa?  What about adding the nomodeset parameter?
Comment 4 Tommaso Visconti 2009-09-09 11:13:59 EDT
I tried with the "basic video driver" option from the boot menu, this includes the nomodeset parameter. I'm not sure if it includes the vesa driver too, i'll try later
Comment 5 Chris Lumens 2009-09-09 11:19:25 EDT
Yes, it includes both those parameters already.  The fact that the machine is basically completely locked up and can only be interacted with via the power button makes this sound like a kernel issue to me.
Comment 6 Tommaso Visconti 2009-09-09 12:13:48 EDT
lol
There's nothing i can do to understand what happens?
Someone suggests me to try with both cd and dvd because on old macbooks only one of them booted properly. Do you think it could be possible?
Comment 7 Bug Zapper 2009-11-16 07:00:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 James Laska 2009-12-12 12:44:37 EST
I've managed to install Fedora 12 Final on a macbook pro 5,5 13.3".  Can the reporter try with F-12-Final to confirm they are also no longer experiencing this issue?
Comment 9 Chuck Ebbert 2010-08-27 14:48:15 EDT

*** This bug has been marked as a duplicate of bug 528232 ***