Bug 521536

Summary: setroubleshoot: SELinux is preventing prelink "add_name" access on slashem.#prelink#.6VX1KB.
Product: [Fedora] Fedora Reporter: Sebastiano M. Cossu <sebastianocossu>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:85fce0653e69355a2773353ade8a9ed898c793bbed0b195d6bdd90ec0b673869
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-07 11:17:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sebastiano M. Cossu 2009-09-06 20:48:09 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing prelink "add_name" access on slashem.#prelink#.6VX1KB.

Descrizione dettagliata:

[prelink has a permissive type (prelink_t). This access was not denied.]

SELinux denied access requested by prelink. It is not expected that this access
is required by prelink and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:prelink_t:s0-s0:c0.c1023
Contesto target               system_u:object_r:games_exec_t:s0
Oggetti target                slashem.#prelink#.6VX1KB [ dir ]
Sorgente                      prelink
Percorso della sorgente       /usr/sbin/prelink
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        prelink-0.4.2-2.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.199.rc8.git2.fc12.i686 #1 SMP
                              Wed Sep 2 21:10:11 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   dom 06 set 2009 12:42:27 CEST
Ultimo visto                  dom 06 set 2009 12:42:27 CEST
ID locale                     620f9be7-d723-4262-9f92-40bc3c33d930
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252233747.124:37): avc:  denied  { add_name } for  pid=4533 comm="prelink" name="slashem.#prelink#.6VX1KB" scontext=system_u:system_r:prelink_t:s0-s0:c0.c1023 tcontext=system_u:object_r:games_exec_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252233747.124:37): arch=40000003 syscall=5 success=yes exit=5 a0=bfcae780 a1=80c2 a2=180 a3=0 items=0 ppid=4524 pid=4533 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="prelink" exe="/usr/sbin/prelink" subj=system_u:system_r:prelink_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= prelink_t ==============
allow prelink_t games_exec_t:dir add_name;

Comment 1 Daniel Walsh 2009-09-07 11:17:08 UTC

*** This bug has been marked as a duplicate of bug 521537 ***