Bug 521538

Summary: setroubleshoot: SELinux is preventing abrtd "write" access on abrt.
Product: [Fedora] Fedora Reporter: Sebastiano M. Cossu <sebastianocossu>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl, pavel.mikula, rodd, sebastianocossu
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:393e91adb14c1f65e164d034ace128e9b373dd89442c8beed2e779ddc34a8270
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-07 11:14:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sebastiano M. Cossu 2009-09-06 20:51:56 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing abrtd "write" access on abrt.

Descrizione dettagliata:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:initrc_t:s0
Contesto target               system_u:object_r:abrt_var_cache_t:s0
Oggetti target                abrt [ dir ]
Sorgente                      abrtd
Percorso della sorgente       /usr/sbin/abrtd
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        abrt-0.0.8.5-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              4
Primo visto                   dom 06 set 2009 19:28:36 CEST
Ultimo visto                  dom 06 set 2009 19:28:36 CEST
ID locale                     0ab7fb9b-e56a-4cd7-b010-90eeb2586d9a
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252258116.231:29): avc:  denied  { write } for  pid=1244 comm="abrtd" name="abrt" dev=dm-0 ino=614441 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252258116.231:29): avc:  denied  { add_name } for  pid=1244 comm="abrtd" name="kerneloops-1252258116-2.lock" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252258116.231:29): avc:  denied  { create } for  pid=1244 comm="abrtd" name="kerneloops-1252258116-2.lock" scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1252258116.231:29): avc:  denied  { write open } for  pid=1244 comm="abrtd" name="kerneloops-1252258116-2.lock" dev=dm-0 ino=528462 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252258116.231:29): arch=40000003 syscall=5 success=yes exit=7 a0=81523f4 a1=c1 a2=1a0 a3=bfc97474 items=0 ppid=1 pid=1244 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir { write add_name };
allow initrc_t abrt_var_cache_t:file { write create open };

Comment 1 Daniel Walsh 2009-09-07 11:14:17 UTC

*** This bug has been marked as a duplicate of bug 521541 ***