Bug 521783

Summary: setroubleshoot: SELinux is preventing libvirtd "write" access on /var/cache/libvirt.
Product: [Fedora] Fedora Reporter: Matěj Cepl <mcepl>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dwalsh, jkubin, mcepl, mgrepl, PTrenholme
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:dcb1e28c114090e11a4f0f8d1a903260a05eb33e2cd8ed68a054891ab81d7d78
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-08 14:36:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matěj Cepl 2009-09-08 10:17:52 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing libvirtd "write" access on /var/cache/libvirt.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by libvirtd. It is not expected that this access
is required by libvirtd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Další informace:

Kontext zdroje                system_u:system_r:virtd_t:s0-s0:c0.c1023
Kontext cíle                 system_u:object_r:svirt_cache_t:s0
Objekty cíle                 /var/cache/libvirt [ dir ]
Zdroj                         libvirtd
Cesta zdroje                  /usr/sbin/libvirtd
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          libvirt-0.7.1-0.1.git3ef2e05.fc12
RPM balíčky cíle           libvirt-0.7.1-0.1.git3ef2e05.fc12
RPM politiky                  selinux-policy-3.6.30-4.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-0.204.rc9.fc12.x86_64 #1 SMP
                              Sat Sep 5 20:45:55 EDT 2009 x86_64 x86_64
Počet upozornění           3
Poprvé viděno               Út 8. září 2009, 12:11:01 CEST
Naposledy viděno             Út 8. září 2009, 12:11:01 CEST
Místní ID                   4f8a5592-dc34-46cd-92b3-b5d325c48862
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252404661.208:26): avc:  denied  { write } for  pid=1718 comm="libvirtd" name="libvirt" dev=dm-1 ino=75590 scontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:svirt_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252404661.208:26): avc:  denied  { add_name } for  pid=1718 comm="libvirtd" name="qemu" scontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:svirt_cache_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1252404661.208:26): avc:  denied  { create } for  pid=1718 comm="libvirtd" name="qemu" scontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:svirt_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252404661.208:26): arch=c000003e syscall=83 success=yes exit=0 a0=22e0440 a1=1ff a2=0 a3=7fffac889cf0 items=0 ppid=1 pid=1718 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="libvirtd" exe="/usr/sbin/libvirtd" subj=system_u:system_r:virtd_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= virtd_t ==============
allow virtd_t svirt_cache_t:dir { write create add_name };

Comment 1 Daniel Walsh 2009-09-08 14:36:28 UTC

*** This bug has been marked as a duplicate of bug 521784 ***