Bug 522016

Summary: system is extremely slow when booting to the login screen and desktop, high X CPU usage
Product: [Fedora] Fedora Reporter: Caspar Zhang <czhang>
Component: xorg-x11-drv-intelAssignee: Kristian Høgsberg <krh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: ajax, awilliam, caiqian, martin.sourada, xgl-maint
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-13 16:00:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
smoltprofile.txt
none
Xorg.Log
none
dmesg info
none
Xorg log file -- Dell Inspiron Mini 9
none
lspci -vv (Dell Inspiron Mini 9)
none
lspci -nn none

Description Caspar Zhang 2009-09-09 02:55:41 EDT
Created attachment 360166 [details]
smoltprofile.txt

Description of problem:

When turned off the KMS and try to boot system, it became very very slow, I kept waiting for 15 minutes to see the desktop environment(While KMS enabled in the cmdline, system went into desktop at a normal speed). The cursor was blinking with "busy" state, just like the system was loading many applications.

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.8.0-11.20090908.fc12.i686

How reproducible:

Always

Steps to Reproduce:
1. Follow the instruction: https://fedoraproject.org/wiki/QA:Testcase_intelvideo_nokms
2.
3.
  
Actual results:

System is slow to enter the desktop environment.

Expected results:

System should enter the desktop environment at a normal speed.

Additional info:
Comment 1 Caspar Zhang 2009-09-09 02:57:00 EDT
Created attachment 360167 [details]
Xorg.Log
Comment 2 Caspar Zhang 2009-09-09 02:57:22 EDT
Created attachment 360168 [details]
dmesg info
Comment 3 Caspar Zhang 2009-09-10 03:31:58 EDT
I use Testday-20090909.iso today for testing, and I found when KMS is enabled, the system is still very slow. I could see a high CPU usage(about 15%-35%) of X process on top.
Comment 4 Martin Sourada 2009-09-13 13:13:23 EDT
I noticed everything in X is terribly slow, I haven't even managed to log in from init 5, startx from init 3 got me working, but it looks like screen is refreshed about once per second and starting even small application like the run app applet took about 15 minutes... Everything in tty seems to work in normal speed though and after switch from X the CPU usage drops after a while from 100 % (used up by X) to almost 0. I've used the Testday-20090909.iso. It's pretty much same with and without KMS.
Comment 5 Michel Alexandre Salim 2009-09-13 17:31:16 EDT
Created attachment 360857 [details]
Xorg log file -- Dell Inspiron Mini 9

On my Dell Inspiron Mini 9 (Intel 945GME), the latest batch of updates:

$ rpm -q xorg-x11-server-Xorg xorg-x11-drv-intel
xorg-x11-server-Xorg-1.6.99.900-1.fc12.i686
xorg-x11-drv-intel-2.8.0-13.20090909.fc12.i686

causes everything to go much slower than before. The system is more-or-less usable with metacity, but I used to be able to run mutter/libgnome-shell with no problem. Now
- with KMS, mutter is totally unusable: the windows would flickr on and off, while the background is displayed OK
- without KMS, mutter is terribly slow. had to switch to metacity to get a usable system
Comment 6 Michel Alexandre Salim 2009-09-13 17:32:31 EDT
Created attachment 360858 [details]
lspci -vv (Dell Inspiron Mini 9)
Comment 7 Caspar Zhang 2009-09-14 03:29:25 EDT
add Regression keyword. Since this bug does not exist in 20090908 but exsits in 20090909. 

intel driver in 20090909 was xorg-x11-drv-intel-2.8.0-13.20090909.fc12.i686 while xorg-x11-drv-intel-2.8.0-11.20090908.fc12.i686 in 20090908. the xorg-x11-server-Xorg version was the same.
Comment 8 CAI Qian 2009-10-01 09:17:57 EDT
Apparently a regression in intel driver, so propose F12 blocker.
Comment 9 Adam Williamson 2009-10-01 15:04:17 EDT
lspci -nn (not -vv) output from all suffering from this problem would be nice.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Martin Sourada 2009-10-01 15:21:13 EDT
Created attachment 363392 [details]
lspci -nn

My lspcsi -nn output. I hope it's OK that it's from F11. I have to also add that I had this issue in the Testday-20090909.iso but not in Snapshot 3 Live (haven't looked which version of the driver is there though).
Comment 11 Adam Williamson 2009-10-01 15:35:10 EDT
yeah, doesn't matter what release it's from.

working in snap3 is hopeful...could you and other sufferers test the latest nightly live CD:

http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

and see how that behaves?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Martin Sourada 2009-10-02 19:38:09 EDT
(In reply to comment #11)
> working in snap3 is hopeful...could you and other sufferers test the latest
> nightly live CD:
> 
> http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/
> 
I've downloaded and tried desktop-i386-20090930.16.iso. I can confirm it works for me.
xorg-x11-drv-intel-2.8.0-16.20090909.fc12.i686
Comment 13 CAI Qian 2009-10-10 05:31:48 EDT
Caspar, please try comment #11 when you are back from the vacation.
Comment 14 Caspar Zhang 2009-10-12 00:54:19 EDT
(In reply to comment #13)
> Caspar, please try comment #11 when you are back from the vacation.  

System works on desktop-i386-20091010.21.iso
Comment 15 Caspar Zhang 2009-10-12 00:57:34 EDT
I tried both with and without KMS, system ran normally when login to desktop. on desktop-i386-20091010.21.iso
Comment 16 Adam Williamson 2009-10-13 16:00:15 EDT
I think we can close this, then. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers