Bug 522021

Summary: setroubleshoot: SELinux is preventing abrtd "setattr" access on kerneloops-1252443345-1.
Product: [Fedora] Fedora Reporter: Chris Ward <cward>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:9026a830ea2231f0f30d1704424fc6ee757a6af4d80338e3f57229fd5daf1dda
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-09 21:22:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Ward 2009-09-09 07:15:00 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing abrtd "setattr" access on kerneloops-1252443345-1.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:abrt_var_cache_t:s0
Target Objects                kerneloops-1252443345-1 [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue
                              Aug 11 21:00:45 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 08 Sep 2009 10:55:45 PM CEST
Last Seen                     Tue 08 Sep 2009 10:55:45 PM CEST
Local ID                      7ba9a965-a8f8-47ea-bcba-b0ac08a7d0f4
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252443345.702:90): avc:  denied  { setattr } for  pid=1436 comm="abrtd" name="kerneloops-1252443345-1" dev=dm-0 ino=116113 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252443345.702:90): arch=c000003e syscall=90 success=yes exit=0 a0=12eb398 a1=1c0 a2=0 a3=7fff9db349b0 items=0 ppid=1 pid=1436 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir setattr;

Comment 1 Daniel Walsh 2009-09-09 21:22:53 UTC
Chris please examine the bugs before submitting them, if they look similar to previous bugs do not submit.  I just have to close as dups and it is a pain in the but.

*** This bug has been marked as a duplicate of bug 522020 ***