Bug 522112

Summary: yum asks for confirmation of empty transaction
Product: [Fedora] Fedora Reporter: Michal Nowak <mnowak>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: ffesti, james.antill, maxamillion, ohudlick, pmatilai, tla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-12 21:54:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michal Nowak 2009-09-09 14:05:35 UTC
Description of problem:

I have a bit messed F-11 -> Rawhide upgrade, with several fc11 packages side by side with theirs fc12 counterparts:

newman@dhcp-lab-124 ~ $ sudo yum upgrade --skip-broken 
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.10.90-21 set to be updated
---> Package glibc.x86_64 0:2.10.90-21 set to be updated
---> Package glibc-common.x86_64 0:2.10.90-21 set to be updated
---> Package glibc-devel.i686 0:2.10.90-21 set to be updated
---> Package glibc-devel.x86_64 0:2.10.90-21 set to be updated
---> Package glibc-headers.x86_64 0:2.10.90-21 set to be updated
---> Package glibc-static.x86_64 0:2.10.90-21 set to be updated
--> Processing Dependency: libgnokii.so.4()(64bit) for package: 6:kdepim-4.3.1-1.fc12.x86_64
--> Processing Dependency: libgnokii.so.4()(64bit) for package: 6:kdepim-4.3.1-1.fc12.x86_64
---> Package gnokii.x86_64 0:0.6.28-1.fc12 set to be updated
--> Processing Conflict: glibc-2.10.90-21.i686 conflicts prelink < 0.4.2
--> Processing Conflict: glibc-2.10.90-21.x86_64 conflicts prelink < 0.4.2
--> Finished Dependency Resolution
glibc-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> glibc conflicts with prelink
glibc-2.10.90-21.i686 from rawhide has depsolving problems
  --> glibc conflicts with prelink
6:kdepim-4.3.1-1.fc12.x86_64 from installed has depsolving problems
  --> Missing Dependency: libgnokii.so.4()(64bit) is needed by package 6:kdepim-4.3.1-1.fc12.x86_64 (installed)
--> Running transaction check
--> Processing Dependency: glibc-common = 2.10.90-20 for package: glibc-2.10.90-20.i686
--> Processing Dependency: glibc-common = 2.10.90-20 for package: glibc-2.10.90-20.x86_64
---> Package glibc.i686 0:2.10.90-21 set to be updated
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-devel-2.10.90-21.x86_64
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-headers-2.10.90-21.x86_64
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-devel-2.10.90-21.i686
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-common-2.10.90-21.x86_64
---> Package glibc.x86_64 0:2.10.90-21 set to be updated
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-devel-2.10.90-21.x86_64
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-headers-2.10.90-21.x86_64
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-devel-2.10.90-21.i686
--> Processing Dependency: glibc = 2.10.90-21 for package: glibc-common-2.10.90-21.x86_64
---> Package gnokii.x86_64 0:0.6.28-1.fc12 set to be updated
--> Finished Dependency Resolution
glibc-2.10.90-20.x86_64 from installed has depsolving problems
  --> Missing Dependency: glibc-common = 2.10.90-20 is needed by package glibc-2.10.90-20.x86_64 (installed)
glibc-headers-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-headers-2.10.90-21.x86_64 (rawhide)
glibc-devel-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-devel-2.10.90-21.x86_64 (rawhide)
glibc-2.10.90-20.i686 from installed has depsolving problems
  --> Missing Dependency: glibc-common = 2.10.90-20 is needed by package glibc-2.10.90-20.i686 (installed)
glibc-common-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-common-2.10.90-21.x86_64 (rawhide)
glibc-devel-2.10.90-21.i686 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-devel-2.10.90-21.i686 (rawhide)
glibc-common-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-common-2.10.90-21.x86_64 (rawhide)
glibc-devel-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-devel-2.10.90-21.x86_64 (rawhide)
glibc-devel-2.10.90-21.i686 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-devel-2.10.90-21.i686 (rawhide)
glibc-headers-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc = 2.10.90-21 is needed by package glibc-headers-2.10.90-21.x86_64 (rawhide)
--> Running transaction check
---> Package glibc-static.x86_64 0:2.10.90-21 set to be updated
--> Processing Dependency: glibc-devel = 2.10.90-21 for package: glibc-static-2.10.90-21.x86_64
--> Finished Dependency Resolution
glibc-static-2.10.90-21.x86_64 from rawhide has depsolving problems
  --> Missing Dependency: glibc-devel = 2.10.90-21 is needed by package glibc-static-2.10.90-21.x86_64 (rawhide)
--> Running transaction check
---> Package glibc-static.x86_64 0:2.10.90-21 set to be updated
--> Finished Dependency Resolution
--> Running transaction check
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    glibc-2.10.90-21.i686 from rawhide
    glibc-2.10.90-21.x86_64 from rawhide
    glibc-common-2.10.90-21.x86_64 from rawhide
    glibc-devel-2.10.90-21.i686 from rawhide
    glibc-devel-2.10.90-21.x86_64 from rawhide
    glibc-headers-2.10.90-21.x86_64 from rawhide
    glibc-static-2.10.90-21.x86_64 from rawhide
    gnokii-0.6.28-1.fc12.x86_64 from rawhide

Dependencies Resolved

===============================================================================================================================================
 Package                              Arch                          Version                               Repository                      Size
===============================================================================================================================================
Skipped (dependency problems):
 glibc                                i686                          2.10.90-21                            rawhide                        2.8 M
 glibc                                x86_64                        2.10.90-21                            rawhide                        2.8 M
 glibc-common                         x86_64                        2.10.90-21                            rawhide                        6.0 M
 glibc-devel                          i686                          2.10.90-21                            rawhide                        946 k
 glibc-devel                          x86_64                        2.10.90-21                            rawhide                        946 k
 glibc-headers                        x86_64                        2.10.90-21                            rawhide                        520 k
 glibc-static                         x86_64                        2.10.90-21                            rawhide                        1.2 M
 gnokii                               x86_64                        0.6.28-1.fc12                         rawhide                        542 k

Transaction Summary
===============================================================================================================================================

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
gnokii-0.6.27-4.fc11.x86_64 was supposed to be removed but is not!
glibc-2.10.1-5.x86_64 was supposed to be removed but is not!

Skipped (dependency problems):
  glibc.i686 0:2.10.90-21            glibc.x86_64 0:2.10.90-21            glibc-common.x86_64 0:2.10.90-21    glibc-devel.i686 0:2.10.90-21   
  glibc-devel.x86_64 0:2.10.90-21    glibc-headers.x86_64 0:2.10.90-21    glibc-static.x86_64 0:2.10.90-21    gnokii.x86_64 0:0.6.28-1.fc12   

Complete!


What I think is weird is that yum knew it has empty transaction, but have asked me to accept it (or not).

Version-Release number of selected component (if applicable):

yum-3.2.24-2.fc12.noarch

Actual results:

"""
Transaction Summary
===============================================================================================================================================

Is this ok [y/N]: y
"""

Expected results:
"""
Transaction Summary
===============================================================================================================================================

Transaction empty, sorry...
"""

Comment 1 seth vidal 2009-09-09 19:37:09 UTC
can you still make this happen? if I get you a patch can you test it?

Comment 2 Tim Lauridsen 2009-09-10 06:26:20 UTC
Try to run "sudo yum upgrade --skip-broken -d5" to give a better look of what i skip-broken is doing

Comment 3 Michal Nowak 2009-09-11 14:15:33 UTC
I'll try to undo the transaction and mess the system again up, and will see. On Monday will tell you.

Comment 4 Michal Nowak 2009-09-16 08:54:14 UTC
Was not able to undo it, sorry.

Comment 5 Michal Nowak 2009-09-16 11:04:20 UTC
Happened again.

newman@dhcp-lab-124 ~ $ sudo yum upgrade --skip-broken -d5
Not loading "blacklist" plugin, as it is disabled
Not loading "whiteout" plugin, as it is disabled
Loaded plugins: dellsysidplugin2, presto, refresh-packagekit
Config time: 0.298
Yum Version: 3.2.24
Setting up Package Sacks
pkgsack time: 0.131
rpmdb time: 0.091
Setting up Upgrade Process
Updating Everything
Building updates object
up:Obs Init time: 0.165
up:simple updates time: 0.427
up:obs time: 0.010
up:condense time: 0.000
updates time: 3.098
Resolving Dependencies
--> Running transaction check
Checking deps for xorg-x11-server-Xorg.x86_64 0-1.6.3-4.fc11 - None
Checking deps for xorg-x11-server-Xorg.x86_64 0-1.6.99.900-1.fc12 - None
---> Package xorg-x11-server-Xorg.x86_64 0:1.6.99.901-1.fc12 set to be updated
Checking deps for xorg-x11-server-Xorg.x86_64 0-1.6.99.901-1.fc12 - u
looking for ('xorg-x11-server-common', 'GE', ('0', '1.6.99.901', '1.fc12')) as a requirement of xorg-x11-server-Xorg.x86_64 0-1.6.99.901-1.fc12 - u
--> Processing Conflict: xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 conflicts libpciaccess < 0.10.6-1
xorg-x11-server-Xorg conflicts with libpciaccess
--> Finished Dependency Resolution
Dependency Process ending
xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 from rawhide has depsolving problems
  --> xorg-x11-server-Xorg conflicts with libpciaccess
Skip-broken round 1
TSINFO: Current Transaction : 3 member(s) 
  updated     : xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64
  updated     : xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64
  update      : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 
                   updates : xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64
SKIPBROKEN: removing xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 from pkgSack & updates
SKIPBROKEN: removing xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 from transaction
SKIPBROKEN: removing xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64 from transaction
--> Running transaction check
Checking deps for xorg-x11-server-Xorg.x86_64 0-1.6.3-4.fc11 - None
--> Finished Dependency Resolution
Dependency Process ending
SKIPBROKEN: sanity check the current transaction
--> Running transaction check
Checking deps for xorg-x11-server-Xorg.x86_64 0-1.6.3-4.fc11 - None
--> Finished Dependency Resolution
Dependency Process ending
Skip-broken took 1 rounds 

Packages skipped because of dependency problems:
    xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 from rawhide
TSINFO: Current Transaction : 1 member(s) 
  updated     : xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64
Skip-Broken time: 0.143
Depsolve time: 5.815

Dependencies Resolved

=============================================================================================================================================================
 Package                                      Arch                           Version                                   Repository                       Size
=============================================================================================================================================================
Skipped (dependency problems):
 xorg-x11-server-Xorg                         x86_64                         1.6.99.901-1.fc12                         rawhide                         1.2 M

Transaction Summary
=============================================================================================================================================================

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
rpm_check_debug time: 0.004
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Transaction Test time: 0.002
Running Transaction
Warning: scriptlet or other non-fatal errors occurred during transaction.
xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 was supposed to be removed but is not!
Transaction time: 0.040

Skipped (dependency problems):
  xorg-x11-server-Xorg.x86_64 0:1.6.99.901-1.fc12                                                                                                            

Complete!



Seth: Feel free to provide the patch, I can test it.

Comment 6 Tim Lauridsen 2009-09-16 13:43:23 UTC
This look a little strange

TSINFO: Current Transaction : 3 member(s) 
  updated     : xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64
  updated     : xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64
  update      : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 
                   updates : xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64


Look like you have 2 versions of xorg-x11-server-Xorg installed
xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64
xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64

The update
xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64 

update both packages, but only have a direct relation to 
xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64

So when the update get removed from the transaction then only

  updated     : xorg-x11-server-Xorg-1.6.99.900-1.fc12.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64

get remove too and the

  updated     : xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64 
                   updatedby : xorg-x11-server-Xorg-1.6.99.901-1.fc12.x86_64

is left behind.

try to run 
package-cleanup --dupes 

to list the dupes and
package-cleanup --cleandupes 

to get rid of the dupes.

I will find a way to make the skip broken code handle this in a more sane way

Comment 7 Michal Nowak 2009-09-16 14:21:20 UTC
Tim: See comment 0, I know I have a bit broken system. Thanks for taking care of this.

Comment 8 Tim Lauridsen 2009-09-17 05:08:01 UTC
I have fixed upstream to take care of this special case.

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=7b0868bfcacb950266753301b551eca8bc5366ee

Comment 9 Michal Nowak 2009-09-17 08:45:22 UTC
Nice to see regression test :). Thanks for the fix.

Comment 10 Tim Lauridsen 2009-09-17 12:19:19 UTC
The only way to fix these skipbroken cases, it is normally impossible to reproduce the users transaction in the real world :)

Comment 11 Fedora Update System 2009-09-30 01:39:27 UTC
yum-3.2.24-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-10-19 16:45:55 UTC
yum-3.2.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.24-2.fc10

Comment 13 Fedora Update System 2009-11-04 12:06:47 UTC
yum-3.2.24-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.