Bug 522132

Summary: system-config-printer hangs with high cpu utilization
Product: [Fedora] Fedora Reporter: Francisco Moraes <francisco.moraes>
Component: system-config-printerAssignee: Tim Waugh <twaugh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: fabrice, jpopelka, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 1.1.13-3.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-09 03:34:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Francisco Moraes 2009-09-09 14:46:34 UTC
Description of problem:

Running system-config-printer on my updated FC11 T60p machine hangs with high CPU utilization. Even after several minutes, the window doesn't repaint nor shows the available printers. Running system-config-printer --debug shows the following:

Connected as user root
refresh
Created subscription 59
<monitor.Monitor instance at 0x8c0c7ec>: printers and jobs lists provided
update_jobs
Authentication pass: 1
Authentication: password callback set
Authentication pass: 1
Authentication: password callback set
Authentication pass: 1
Authentication: password callback set

Version-Release number of selected component (if applicable):

system-config-printer-1.1.8-6.fc11.i586

How reproducible:

Every time on this computer.

Steps to Reproduce:
1. run system-config-printer
  
Actual results:

Window frame shows up, CPU spikes, but no content shown.

Expected results:

Available printers listed.

Additional info:

Comment 1 Francisco Moraes 2009-09-09 14:54:20 UTC
Found a similar bug reported in Ubuntu:

https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/343625

Comment 2 Fabrice Bellet 2009-09-11 11:37:20 UTC
I see the same behaviour. Starting s-c-p with cups stopped is a possible workaround.

Comment 3 Tim Waugh 2009-09-14 10:51:38 UTC
Please try the test update:
  https://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Does it fix the problem?

Comment 4 Francisco Moraes 2009-09-14 12:26:45 UTC
Yes, the problem is fixed by the test update. Is there one of the bugs that fixed this issue?

Comment 5 Tim Waugh 2009-09-14 15:33:04 UTC
I don't think it had been filed in Bugzilla.

Comment 6 Fedora Update System 2009-09-15 07:49:37 UTC
system-config-printer-1.1.13-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Comment 7 Fedora Update System 2009-09-24 05:08:38 UTC
system-config-printer-1.1.13-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Comment 8 Fedora Update System 2009-10-03 19:10:21 UTC
system-config-printer-1.1.13-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8108

Comment 9 Fedora Update System 2009-10-09 03:32:46 UTC
system-config-printer-1.1.13-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.