Bug 522293

Summary: setroubleshoot: SELinux is preventing abrtd "lock" access on /var/cache/abrt/kerneloops-1252258116-1.lock.
Product: [Fedora] Fedora Reporter: Sebastiano M. Cossu <sebastianocossu>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:85321a33c853a98fe4b3e3f93d489d250604e648f646bb5361e91fbae6c66f18
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-10 08:16:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sebastiano M. Cossu 2009-09-10 01:49:21 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing abrtd "lock" access on
/var/cache/abrt/kerneloops-1252258116-1.lock.

Descrizione dettagliata:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:initrc_t:s0
Contesto target               system_u:object_r:abrt_var_cache_t:s0
Oggetti target                /var/cache/abrt/kerneloops-1252258116-1.lock [
                              file ]
Sorgente                      abrtd
Percorso della sorgente       /usr/sbin/abrtd
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        abrt-0.0.8.5-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   gio 10 set 2009 03:34:02 CEST
Ultimo visto                  gio 10 set 2009 03:34:02 CEST
ID locale                     ba90c73b-f084-491c-b959-11bbc628f3e0
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252546442.454:17): avc:  denied  { lock } for  pid=1242 comm="abrtd" path="/var/cache/abrt/kerneloops-1252258116-1.lock" dev=dm-0 ino=528671 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252546442.454:17): arch=40000003 syscall=221 success=yes exit=0 a0=7 a1=7 a2=bf9e72b0 a3=bf9e72b0 items=0 ppid=1 pid=1242 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:file lock;

Comment 1 Miroslav Grepl 2009-09-10 08:16:12 UTC

*** This bug has been marked as a duplicate of bug 522020 ***