Bug 522303

Summary: setroubleshoot: SELinux is preventing abrtd "setattr" access on kerneloops-1252547180-2.
Product: [Fedora] Fedora Reporter: Sebastiano M. Cossu <sebastianocossu>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:744632e04c8ee91edafc9dab244fb3927c6038aa8ae416f88e5178f1742edee6
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-10 07:54:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sebastiano M. Cossu 2009-09-10 01:59:27 UTC
The following was filed automatically by setroubleshoot:

Sommario:

SELinux is preventing abrtd "setattr" access on kerneloops-1252547180-2.

Descrizione dettagliata:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Abilitazione accesso in corso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Informazioni aggiuntive:

Contesto della sorgente       system_u:system_r:initrc_t:s0
Contesto target               system_u:object_r:abrt_var_cache_t:s0
Oggetti target                kerneloops-1252547180-2 [ dir ]
Sorgente                      abrtd
Percorso della sorgente       /usr/sbin/abrtd
Porta                         <Sconosciuto>
Host                          (removed)
Sorgente Pacchetti RPM        abrt-0.0.8.5-1.fc12
Pacchetti RPM target          
RPM della policy              selinux-policy-3.6.30-2.fc12
Selinux abilitato             True
Tipo di policy                targeted
MLS abilitato                 True
Modalità Enforcing           Enforcing
Nome plugin                   catchall
Host Name                     (removed)
Piattaforma                   Linux (removed) 2.6.31-0.204.rc9.fc12.i686 #1 SMP Sat
                              Sep 5 21:01:10 EDT 2009 i686 i686
Conteggio avvisi              1
Primo visto                   gio 10 set 2009 03:46:20 CEST
Ultimo visto                  gio 10 set 2009 03:46:20 CEST
ID locale                     a1979bf0-e559-4f40-9114-ce5436e90ebe
Numeri di linea               

Messaggi Raw Audit            

node=(removed) type=AVC msg=audit(1252547180.317:33): avc:  denied  { setattr } for  pid=1288 comm="abrtd" name="kerneloops-1252547180-2" dev=dm-0 ino=622707 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252547180.317:33): arch=40000003 syscall=15 success=yes exit=0 a0=981a82c a1=1c0 a2=6da368 a3=bfd0b044 items=0 ppid=1 pid=1288 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:dir setattr;

Comment 1 Miroslav Grepl 2009-09-10 07:54:53 UTC

*** This bug has been marked as a duplicate of bug 522020 ***