Bug 52236

Summary: Sendmail appears to be outputting crap
Product: [Retired] Red Hat Linux Reporter: Matthew Galgoci <mgalgoci>
Component: sendmailAssignee: Florian La Roche <laroche>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: alan, mgalgoci
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-08-21 16:41:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matthew Galgoci 2001-08-21 16:41:37 EDT
----- Transcript of session follows -----                               
                                                                          
                  ... while talking to mrsmith.divxnetworks.com.:         
                                                                          
                                    >>> MAIL From:<alan@somedomain.com>
SIZE=707 AUTH=alan@mailhost.somedomain.com                                
                                                            <<< 501 5.5.4
Invalid arguments                                                         
                                                                          
    501 5.6.0 ikusnitsav@msimserverusingcompany.com... Data format error  
                                                                          
                                                                          
                                                                          
                                                  

There are multiple sites I now have to mail form non Red Hat boxes that   
                                                                          
                  report variants on the above error                      
                                                                          
                                                                          
                                                                          
                                                      

It appears the weird SIZE=707 AUTH=alan@mailhost.somedomain.com stuff     
                                                                          
                 breaks Microsoft mail servers.
Comment 1 Florian La Roche 2001-08-23 03:38:45 EDT
On a RHL 7.0 system, please make sure you update glibc to the errata
version as that fixes many problems. I'd also recommend upating to RHL 7.1
for a mail server system.

The sendmail documentation also refers to some fixpacks you need to
apply to that other operating system, so that this other operating system
works correctly. AFAIK sendmail should be ok.

Florian La Roche