Bug 522382

Summary: setroubleshoot: SELinux is preventing abrtd "lock" access on /var/cache/abrt/kerneloops-1252573682-1.lock.
Product: [Fedora] Fedora Reporter: Rodd Clarkson <rodd>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:7b644946eec5c82f90ac27d36de8877f9aa656cf89407789ea35d2bde6edd3c6
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-10 11:25:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rodd Clarkson 2009-09-10 09:09:16 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing abrtd "lock" access on
/var/cache/abrt/kerneloops-1252573682-1.lock.

Detailed Description:

[abrtd has a permissive type (initrc_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi) against this package.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:abrt_var_cache_t:s0
Target Objects                /var/cache/abrt/kerneloops-1252573682-1.lock [
                              file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.30-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.x86_64 #1 SMP Tue
                              Aug 11 21:00:45 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 10 Sep 2009 19:08:02 EST
Last Seen                     Thu 10 Sep 2009 19:08:02 EST
Local ID                      a2320980-5604-4049-8008-37253164f563
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252573682.548:39): avc:  denied  { lock } for  pid=1242 comm="abrtd" path="/var/cache/abrt/kerneloops-1252573682-1.lock" dev=dm-5 ino=130744 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:abrt_var_cache_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252573682.548:39): arch=c000003e syscall=72 success=yes exit=0 a0=7 a1=7 a2=7fffc5998da0 a3=1 items=0 ppid=1 pid=1242 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:initrc_t:s0 key=(null)


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t abrt_var_cache_t:file lock;

Comment 1 Miroslav Grepl 2009-09-10 11:25:41 UTC

*** This bug has been marked as a duplicate of bug 522020 ***