Bug 522445

Summary: openmpi-1.3.3-3.el6 fails to build on s390x
Product: Red Hat Enterprise Linux 6 Reporter: Karsten Hopp <karsten>
Component: openmpiAssignee: Doug Ledford <dledford>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 6.0   
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-15 13:56:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 522407    

Description Karsten Hopp 2009-09-10 11:15:25 UTC
Description of problem:
openmpi-1.3.3-3.el6 failed to build during the mass rebuild for RHEL6.
Failure reasons are packages that aren't available on s390x such as valgrind and numactl. But even without those packages listed as build requirements the build failes with 
> checking prefix for function in .type... @
> checking if .size is needed... yes
> checking if .align directive takes logarithmic value... no
> configure: error: No atomic primitives available for s390x-ibm-linux-gnu

If there is no support at all for s390x in this package, s390 and s390x should be listed in ExcludeArch

Version-Release number of selected component (if applicable):
openmpi-1.3.3-3.el6  (just a rebuild of openmpi-1.3.3-3.fc12)

  
Actual results:
https://brewweb.devel.redhat.com/taskinfo?taskID=1960811

Comment 2 RHEL Program Management 2009-09-10 11:46:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Doug Ledford 2009-09-15 13:56:13 UTC
Latest Fedora openmpi uses ExcludeArch for s390/s390x because there are dependent packages that don't exist on s390(x).