Bug 522916

Summary: NetworkManager does not recognize auto IPv6 configuration
Product: [Fedora] Fedora Reporter: A.J. Werkman <aj.werkman>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: dcbw, fedora-bugzilla, maurizio.antillon, monomartin
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-04-23 16:22:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description A.J. Werkman 2009-09-12 03:27:12 EDT
Description of problem:
NetworkManager does not recognize the IPv6 state of an interface auto configured by the kernel

Version-Release number of selected component (if applicable):
0.7.996-1.git20090826

How reproducible:
Everytime

Steps to Reproduce:
1. Start Fedora in an IPv6 only network with radvd active on a router.
2. See that IPv4 DHCP will not configure an IPv4 addresssing scheme.
3. On the desktop Fedora reports no network connection.
4. Open a terminal session and do "ifconfig eth0".
5. See that IPv6 addresses are configured according to the radvd settings.
  
Actual results:
It is not possible to switch off IPv4. Every boot DHCP wants to find an IPv4 address and it will fail. And I know in advance it will not find IPv4 info.
Although there is network connectivity NM reports "no network" and the IPv6 tab in the wired interface section of NM reports "Ignore". Switching to "Automatic" is not possible. NM always comes back with "Ignore".
resolv.conf has no entry, so name lookup is not possible. When I manually add an IPv6 nameserver address to resolv.conf I can lookup names and applikations like firefox operate as expected.

Expected results:
When booting in an IPv6 only network IPv4 should be switched off and IPv6 should be configured/recognized and name resolution should be possible. NM must be able to configure IPv6 instead of ignoring it.


Additional info:
Comment 1 Dan Williams 2009-11-06 22:50:27 EST
Please try with latest Fedora rawhide updates!  There have been a few fixes to IPv6 support in NetworkManager that may fix your issue.  Let me know, thanks!
Comment 2 Catalin BOIE 2009-11-09 10:37:26 EST
I used 0.7.996-6.git20091021.fc12 and "Selecting IPv6 Settings -> Automatic -> Apply -> Edit -> IPv6 Settings -> Boom! It is on "Ignore", not "Automatic"!
Comment 3 A.J. Werkman 2009-11-09 14:00:34 EST
My status report as off today NM-applet version 07.7.996:

At this moment I can change to IPv6 tab and change "ignore" to "Manual". After selecting the button "add" I can type a IPv6 address and prefix. This makes the "apply" button to change from grey (inselectable) to normal selectable. When I hit the apply button it seems that NM is accepting my IPv6 address. But when I reselect the IPv6 tab the screen is back on "Ignore" again.

I also do not see the given IPv6 address in the output of "ifconfig eth0" command. So cosmetically it looks like the function is working, but it gives no real effect.
Comment 4 A.J. Werkman 2009-11-09 14:03:38 EST
Sorry, forgot to list my installed NetworkManager rpm's. Here they are:


NetworkManager-pptp-0.7.996-4.git20090921.fc12.i686
NetworkManager-glib-0.7.996-6.git20091021.fc12.i686
NetworkManager-openvpn-0.7.996-4.git20090923.fc12.i686
NetworkManager-0.7.996-6.git20091021.fc12.i686
NetworkManager-vpnc-0.7.996-4.git20090921.fc12.i686
NetworkManager-gnome-0.7.996-6.git20091021.fc12.i686
Comment 5 Bug Zapper 2009-11-16 07:18:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Dan Williams 2010-01-20 19:33:39 EST
Is this bug still an issue with https://admin.fedoraproject.org/updates/NetworkManager-0.7.998-1.git20100106.fc12 ?
Comment 7 A.J. Werkman 2010-02-01 09:03:45 EST
Dan,

I still see the same behaviour with NetworkManager-0.7.999 from rawhide.

The network icon at the top of the screen reports no network, but over IPv6 I can still browse IPv6 capable websites and ifconfig eth0 also reports IPv6 auto configured addresses.

Network Manager reports 'Ignore' in the 'IPv6 settings'-tab.

It looks like NetworkManager is not reading the IPV6 data that is autoconfigured by the kernel.
Comment 8 Dan Williams 2010-02-08 20:44:23 EST
Actually, these days the IPv6 method should be set to "automatic", which will handle all the autoconf stuff including udpating /etc/resolv.conf with nameservers from your router.  If you make that change, does that cause NM to report the right state?
Comment 9 Catalin BOIE 2010-02-09 02:30:45 EST
Seems that NetworkManager (latest in Fedora 12), setting a connection to automatic, does not respect radvd to request an IP by DHCPv6. May not be related to this bug report, but...
I will try to debug NetworkManager when I will have time.
Comment 10 Dan Williams 2010-03-01 21:53:23 EST
(In reply to comment #9)
> Seems that NetworkManager (latest in Fedora 12), setting a connection to
> automatic, does not respect radvd to request an IP by DHCPv6. May not be
> related to this bug report, but...
> I will try to debug NetworkManager when I will have time.    

Updated builds support radvd-requested DHCPv6; I think they are in F12 updates-testing and are already in F13.  It's still a bit rough but it should work.  Testing of:

http://koji.fedoraproject.org/koji/buildinfo?buildID=157530

would be appreciated!

You still can't turn off IPv4 though, so the original bug report is not yet fixed.
Comment 11 Dan Williams 2010-04-23 16:22:36 EDT

*** This bug has been marked as a duplicate of bug 538499 ***