This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 522998

Summary: remove libcanberra-gtk2 dependency on gdm
Product: [Fedora] Fedora Reporter: Daniel Mach <dmach>
Component: libcanberraAssignee: Kevin Kofler <kevin>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: fedora, kevin, lpoetter, mclasen, mmaslano, notting, orion, projects.rg, smparrish
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.17-2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-16 18:22:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473302    

Description Daniel Mach 2009-09-13 03:42:37 EDT
I have a KDE desktop and I don't want to install gdm (I use kdm instead).
When I exclude it from yum update, I get this:
  --> Missing Dependency: gdm is needed by package libcanberra-gtk2-0.17-1.fc12.i686 (rawhide)

Is it possible to remove this dependency?
I don't see any reason why a sound library would require a login manager.
Comment 1 Lennart Poettering 2009-09-13 16:26:01 EDT
libcanberra-gtk2 places some files in directories created by the gdm package such as /usr/share/gdm/autostart/LoginWindow/. It thus needs to pull in gdm.
Comment 2 Matthias Clasen 2009-09-13 20:51:18 EDT
This might be a case where duplicate ownership for the directory is appropriate.
Comment 3 Daniel Mach 2009-09-15 06:50:53 EDT
Can you split it to a new subpackage libcanberra-gdm?
That would solve the problem.
Comment 4 Marcela Mašláňová 2009-09-15 06:55:40 EDT
I wonder why I need gdm and another dependent packages. I removed gdm with all new dependencies and sound works.

libcanberra-gtk2
pulseaudio-gdm-hooks

These requieres doesn't make sense to me. Who requires these two and why they were installed when I don't need them?
Comment 5 Sebastian Vahl 2009-09-15 10:28:59 EDT
This newly introduced dependency on gdm will also pull some unneeded gnome packages into the KDE live images (which will increase the size by ~30 megs). So please use a duplicate ownership or a subpackage for this.
Comment 6 Kevin Kofler 2009-09-15 10:40:51 EDT
+1, requiring a display manager in an application-level library just doesn't make sense from a logical perspective and it bloats the KDE Live image (as gdm in turn directly or indirectly drags in a lot of other GNOME stuff and even xulrunner), those directories really need to be co-owned in this case.

(The reason libcanberra-gtk2 ends up on the KDE live image in the first place is that firstboot requires metacity which requires libcanberra-gtk2. We also still ship pavucontrol which also requires libcanberra-gtk2, but that one could be dropped, firstboot can't. ;-) )
Comment 7 Lennart Poettering 2009-09-15 19:06:48 EDT
If someone of our KDE-loving friends wants to split off  /usr/share/gdm/autostart/LoginWindow/libcanberra-ready-sound.desktop into a seperate package libcanberra-gdm-hooks that is pulled in by gdm he's welcome to do that. I am not the only one with commit access to gdm/libcanberra's rpm cvs.
Comment 8 Kevin Kofler 2009-09-15 20:28:33 EDT
So you prefer a subpackage for just the one file rather than just having libcanberra-gtk2 own the /usr/share/gdm/autostart/LoginWindow/ hierarchy together with gdm? I can easily implement that (the subpackage) if that's how you want things done.
Comment 9 Kevin Kofler 2009-09-15 20:30:08 EDT
(Be warned that the dependency will be circular though: libcanberra-gdm-hooks requiring gdm for directory ownership and gdm requiring libcanberra-gdm-hooks because something has to and it can't be libcanberra-gtk2 because then it'd be dragging in gdm again.)
Comment 10 Bill Nottingham 2009-09-15 23:27:00 EDT
.... just own the directory. Simplest answers are best.
Comment 11 Kevin Kofler 2009-09-16 18:15:55 EDT
* Wed Sep 16 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.17-2
- Don't require gdm in -gtk2 (#522998)
Comment 12 Lennart Poettering 2009-09-16 22:51:32 EDT
(In reply to comment #10)
> .... just own the directory. Simplest answers are best.  

Which is not really what the policy says... (Unless your proposal geoes through of course)