This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 523135

Summary: circular obsoletes in mstflint, perftest, and tvflash (again!)
Product: Red Hat Enterprise Linux 5 Reporter: Radek Bíba <rbiba>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED ERRATA QA Contact: Petr Sklenar <psklenar>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.4CC: atodorov, csimpson, dgregor, dledford, gozen, james.antill, jason.dunn, jburke, jhutar, jim, jlaska, jlee23, jswhite, mgahagan, philippe+bugzilla, psklenar, ralston, riek, syeghiay, tao, tis
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 448772 Environment:
Last Closed: 2010-03-30 04:29:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 448772    
Bug Blocks:    

Description Radek Bíba 2009-09-14 04:45:43 EDT
+++ This bug was initially created as a clone of Bug #448772 +++

Looks like RHEL 5.4 resurrected this issue, just with a newer version-release in some cases. `yum update' keeps replacing these packages with their openib-* siblings and vice versa:

# yum -y update
...
Installed:
  mstflint.i386 0:1.4-1.el5 perftest.i386 0:1.2-14.el5 tvflash.i386 0:0.9.0-2.el5

Replaced:
  openib-mstflint.i386 0:1.2-6.el5_1.1 openib-perftest.i386 0:1.2-6.el5_1.1 openib-tvflash.i386 0:0.9.2-6.el5_1.1

Complete!
# yum -y update
...

Installed:
  openib-mstflint.i386 0:1.2-6.el5_1.1 openib-perftest.i386 0:1.2-6.el5_1.1 openib-tvflash.i386 0:0.9.2-6.el5_1.1

Replaced:
  mstflint.i386 0:1.4-1.el5 perftest.i386 0:1.2-14.el5 tvflash.i386 0:0.9.0-2.el5

This happens on all RHEL 5.4 system I've examined so far, both Client and Server.
Comment 2 Doug Ledford 2009-09-14 11:51:43 EDT
Please note that as of rhel5.4, there was no update to mstflint or tvflash, and although perftest was updated, it did not have any changes to its list of obsoletes.  If this problem has resurfaced then something either in the yum repos or yum itself has changed.
Comment 8 Colin Simpson 2009-10-14 12:50:58 EDT
We are seeing these circular updates too. I'm not sure I know quite when the obsolescence occurred and which one is now the correct one as both are in our updates (prefixed and non-prefixed openib-). But it looks like RH5.4 update of non prefixed openib-* components obsoletes openib-* versions. And then the base in our case pure RH5.0 openib-* obsoletes the 5.4 non prefixed openib-*. So for example,

The 5.4 update tvflash-0.9.0-2.el5 obsoletes openib-tvflash
Then the base (for me a 5.0) openib-tvflash-0.9.1-5.el5 obsoletes tvflash

Here are two subsequent runs of yum update and what we get:
 
Installed:
  mstflint.i386 0:1.4-1.el5             mstflint.x86_64 0:1.4-1.el5            
  perftest.i386 0:1.2-14.el5            perftest.x86_64 0:1.2-14.el5           
  tvflash.i386 0:0.9.0-2.el5            tvflash.x86_64 0:0.9.0-2.el5           

Replaced:
  openib-mstflint.i386 0:1.0.1-5.el5    openib-mstflint.x86_64 0:1.0.1-5.el5   
  openib-perftest.i386 0:1.0.1-5.el5    openib-perftest.x86_64 0:1.0.1-5.el5   
  openib-tvflash.i386 0:0.9.1-5.el5     openib-tvflash.x86_64 0:0.9.1-5.el5    

Then next run:

Installed:
  openib-mstflint.i386 0:1.0.1-5.el5    openib-mstflint.x86_64 0:1.0.1-5.el5   
  openib-perftest.i386 0:1.0.1-5.el5    openib-perftest.x86_64 0:1.0.1-5.el5   
  openib-tvflash.i386 0:0.9.1-5.el5     openib-tvflash.x86_64 0:0.9.1-5.el5    

Replaced:
  mstflint.i386 0:1.4-1.el5             mstflint.x86_64 0:1.4-1.el5            
  perftest.i386 0:1.2-14.el5            perftest.x86_64 0:1.2-14.el5           
  tvflash.i386 0:0.9.0-2.el5            tvflash.x86_64 0:0.9.0-2.el5
Comment 9 Guy Streeter 2009-11-19 13:35:02 EST
bug 511033, bug 510204, and bug 523135 appear to duplicate each other.
Comment 10 Guy Streeter 2009-11-19 13:36:35 EST
oops. bug 510204 is different
Comment 12 Guy Streeter 2009-11-20 15:47:52 EST
bug 524716 is also a dup
Comment 13 Guy Streeter 2009-11-20 15:48:54 EST
*** Bug 524716 has been marked as a duplicate of this bug. ***
Comment 17 Dennis Gregorovic 2009-11-24 10:37:43 EST
FYI, here are the list of packages in the repodata for the rhel-i386-client-workstation-5 channel:

$ grep getPackage primary.xml | egrep '(mstflint|perftest|tvflash)' | sort
    <location href="getPackage/mstflint-1.3-1.el5.i386.rpm" />
    <location href="getPackage/mstflint-1.4-1.el5.i386.rpm" />
    <location href="getPackage/openib-mstflint-1.0.1-5.el5.i386.rpm" />
    <location href="getPackage/openib-mstflint-1.2-6.el5_1.1.i386.rpm" />
    <location href="getPackage/openib-mstflint-1.2-6.el5.i386.rpm" />
    <location href="getPackage/openib-mstflint-1.3-1.el5_2.i386.rpm" />
    <location href="getPackage/openib-perftest-1.0.1-5.el5.i386.rpm" />
    <location href="getPackage/openib-perftest-1.2-11.el5_2.i386.rpm" />
    <location href="getPackage/openib-perftest-1.2-6.el5_1.1.i386.rpm" />
    <location href="getPackage/openib-perftest-1.2-6.el5.i386.rpm" />
    <location href="getPackage/openib-tvflash-0.9.1-5.el5.i386.rpm" />
    <location href="getPackage/openib-tvflash-0.9.2-6.el5_1.1.i386.rpm" />
    <location href="getPackage/openib-tvflash-0.9.2-6.el5.i386.rpm" />
    <location href="getPackage/openib-tvflash-0.9.2-8.el5_2.i386.rpm" />
    <location href="getPackage/perftest-1.2-10.el5.i386.rpm" />
    <location href="getPackage/perftest-1.2-11.el5.i386.rpm" />
    <location href="getPackage/perftest-1.2-14.el5.i386.rpm" />
    <location href="getPackage/tvflash-0.9.0-2.el5.i386.rpm" />
Comment 30 James Antill 2010-02-23 11:58:25 EST
Ok, built yum-3.2.22-26.el5 and tested:

 3.2.29 = works
 3.2.22-25.el5 = fails
 3.2.22-26.el5 = works

...where works == no constant updating. Sorry, for not seeing this sooner Doug!
Comment 32 Doug Ledford 2010-02-23 13:00:49 EST
No worries, glad it's straightened out ;-)
Comment 33 Philippe Brieu 2010-02-24 18:43:22 EST
Any estimate on when we can expect a new "yum" RPM that includes this fix to be released?  Thanks.
Comment 34 James Antill 2010-02-25 09:32:03 EST
Philippe, yum-3.2.22-26.el5 is being tested as part of 5.5 now ... and I don't expect any problems.

If it's a significant problem you can run:

 yum downgrade yum-3.2.19

...although then you'll need to stop yum from updating until >= 3.2.22-26 is out.
Comment 42 Petr Sklenar 2010-03-03 10:35:18 EST
testing procedure:
= pkgB = 
obsoletes pkgA 
= pkgA-1 = 
obsoletes pkgB
= pkgA-2 = 
(no obsoletes)

--- 
no pkg* on system : 'yum install pkgA' will install pkgB, 'yum install pkgB install pkgB' 

only pkgA-1 on system : yum upgrade => installs pkgB

only pkgA-2 on system : yum upgrade => installs pkgB

only pkgB on system : yum upgrade => nothing, yum install pkgA-1 => nothing, yum install pkgA-2 => also nothing

with pkgB installed "yum upgrade" and "yum list obsoletes" does not list pkgA-1 (assuming pkgA-2 is also available).

rhts test created
/CoreOS/yum/Regression/bz523135-circular-obsoletes-in-mstflint

http://cvs.devel.redhat.com/cgi-bin/cvsweb.cgi/tests/yum/Regression/bz523135-circular-obsoletes-in-mstflint/

rhts run=https://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=129803
---
I could also upgrade stable systems
---
Verified with yum-3.2.22-26.el5
Comment 44 errata-xmlrpc 2010-03-30 04:29:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0254.html