Bug 523583

Summary: setroubleshoot: SELinux is preventing the gdm-session-wor from using potentially mislabeled files (root).
Product: [Fedora] Fedora Reporter: kylin <kylinygzeng>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: bpetersxx, dwalsh, jkubin, matt.brundage80, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:d0a4a153c319dde22d434bc87ee82dda174d3006e7c5d40ebf341b8d804d1f3b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-16 12:41:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description kylin 2009-09-16 01:58:11 UTC
The following was filed automatically by setroubleshoot:

概述:

SELinux is preventing the gdm-session-wor from using potentially mislabeled
files (root).

详细描述:

SELinux has denied gdm-session-wor access to potentially mislabeled file(s)
(root). This means that SELinux will not allow gdm-session-wor to use these
files. It is common for users to edit files in their home directory or tmp
directories and then move (mv) them to system directories. The problem is that
the files end up with the wrong file context which confined applications are not
allowed to access.

允许访问:

If you want gdm-session-wor to access this files, you need to relabel them using
restorecon -v 'root'. You might want to relabel the entire directory using
restorecon -R -v 'root'.

附加信息:

源上下文                  system_u:system_r:xdm_t:s0-s0:c0.c1023
目标上下文               system_u:object_r:admin_home_t:s0
目标对象                  root [ dir ]
源                           gdm-session-wor
源路径                     /usr/libexec/gdm-session-worker
端口                        <未知>
主机                        (removed)
源 RPM 软件包             gdm-2.27.4-4.fc12
目标 RPM 软件包          filesystem-2.4.27-1.fc12
策略 RPM                    selinux-policy-3.6.26-8.fc12
启用 Selinux                True
策略类型                  targeted
启用 MLS                    True
Enforcing 模式              Enforcing
插件名称                  home_tmp_bad_labels
主机名                     (removed)
平台                        Linux (removed)
                              2.6.31-0.125.4.2.rc5.git2.fc12.i686.PAE #1 SMP Tue
                              Aug 11 21:01:03 EDT 2009 i686 i686
警报计数                  6
第一个                     2009年09月15日 星期二 19时07分50秒
最后一个                  2009年09月16日 星期三 06时57分02秒
本地 ID                     1e550fd9-b4c4-43e7-a284-6d1fcc7f4c50
行号                        

原始核查信息            

node=(removed) type=AVC msg=audit(1253055422.192:22873): avc:  denied  { write } for  pid=1311 comm="gdm-session-wor" name="root" dev=sda7 ino=73586 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1253055422.192:22873): arch=40000003 syscall=5 success=no exit=-13 a0=9867cd0 a1=80c2 a2=180 a3=1a items=0 ppid=1254 pid=1311 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:dir write;

Comment 1 Daniel Walsh 2009-09-16 12:41:53 UTC
Fixed in the latest rawhide.

yum update

Comment 2 Daniel Walsh 2009-09-16 12:42:18 UTC
*** Bug 523584 has been marked as a duplicate of this bug. ***