Bug 523726

Summary: setroubleshoot: SELinux is preventing /usr/sbin/tmpwatch "setattr" access on autom4te.cache.
Product: [Fedora] Fedora Reporter: STEVEN WARD <stevenward666>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl, stevenward666
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:bf9cd31ebbd63054cc13a0b53b4b5d87005f173ddc650f9bd2a634e4ae9f825f
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-16 16:00:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description STEVEN WARD 2009-09-16 14:32:33 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/tmpwatch "setattr" access on autom4te.cache.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by tmpwatch. It is not expected that this access
is required by tmpwatch and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:tmpreaper_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:usr_t:s0
Target Objects                autom4te.cache [ dir ]
Source                        tmpwatch
Source Path                   /usr/sbin/tmpwatch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           tmpwatch-2.9.15-2
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-rc8 #1 SMP Sat Sep 12
                              23:19:48 BST 2009 i686 athlon
Alert Count                   1
First Seen                    Sun 13 Sep 2009 06:37:51 PM BST
Last Seen                     Sun 13 Sep 2009 06:37:51 PM BST
Local ID                      96fe0ccb-433e-4bf6-8977-eeb6bd6c33c7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1252863471.701:45): avc:  denied  { setattr } for  pid=4173 comm="tmpwatch" name="autom4te.cache" dev=dm-0 ino=98311 scontext=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1252863471.701:45): arch=40000003 syscall=30 success=yes exit=0 a0=804ab86 a1=bfd0fa68 a2=9b71168 a3=0 items=0 ppid=4171 pid=4173 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="tmpwatch" exe="/usr/sbin/tmpwatch" subj=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= tmpreaper_t ==============
allow tmpreaper_t usr_t:dir setattr;

Comment 1 Daniel Walsh 2009-09-16 16:00:10 UTC

*** This bug has been marked as a duplicate of bug 523725 ***