Bug 524027

Summary: setroubleshoot: SELinux is preventing rtkit-daemon "setsched" access.
Product: [Fedora] Fedora Reporter: David <idht4n>
Component: selinux-policyAssignee: Daniel Walsh <dwalsh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:964116e6aed5ec3fc378a623bc00893045b50a59884ca01458bb796e9bca8697
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-17 20:01:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David 2009-09-17 16:19:16 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing rtkit-daemon "setsched" access.

Detailed Description:

SELinux denied access requested by rtkit-daemon. It is not expected that this
access is required by rtkit-daemon and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:initrc_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                None [ process ]
Source                        rtkit-daemon
Source Path                   rtkit-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-1.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-23.fc12.i686.PAE #1 SMP Wed Sep 16 15:53:47
                              EDT 2009 i686 i686
Alert Count                   1
First Seen                    Thu 17 Sep 2009 09:17:00 AM PDT
Last Seen                     Thu 17 Sep 2009 09:17:00 AM PDT
Local ID                      bf059301-3cf0-4340-b17c-4a39f8ca6e92
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253204220.790:49): avc:  denied  { setsched } for  pid=1519 comm="rtkit-daemon" scontext=system_u:system_r:initrc_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


audit2allow suggests:

#============= initrc_t ==============
allow initrc_t unconfined_t:process setsched;

Comment 1 Daniel Walsh 2009-09-17 20:01:01 UTC

*** This bug has been marked as a duplicate of bug 524026 ***