Bug 524261

Summary: dmraid should obsolete dmraid-libs
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: dmraidAssignee: LVM and device-mapper development team <lvm-team>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: agk, bmr, dwysocha, hdegoede, heinzm, lvm-team, mbroz, prockai
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-21 14:27:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 2009-09-18 15:03:25 UTC
Since the dmraid libs have been merged into the main package, the main
package should obsolete dmraid-libs, now when upgrading to rc16 the old rc15 dmraid-libs package stays installed.

Comment 1 Hans de Goede 2009-09-18 15:32:22 UTC
Also the libdmraid.so symlink should be in the -devel package, and the -devel package should Require the main package (now that the lib is in there).

I've done tons of packages (circa 200), do you want me to clean the dmraid spec file up a bit and fix these issues ?

Comment 2 Heinz Mauelshagen 2009-09-19 16:50:01 UTC
As you know, I'm already out to LinuxCon anyway, so please feel free to do so and rebuild for rawhide. Once you're done I can pull in your enhancements into F-11/F-10 cvs.

Thanks,
Heinz

Comment 3 Hans de Goede 2009-09-21 14:27:06 UTC
Fixed in 1.0.0.rc16-2, which is on its way to rawhide.

Comment 4 Hans de Goede 2009-09-21 14:29:08 UTC
Correction, make that 1.0.0.rc16-3, for some reason there already is a cvs tag for -2.