Bug 524296

Summary: Missing linefeeds in debug output
Product: [Fedora] Fedora Reporter: Bastien Nocera <bnocera>
Component: vinagreAssignee: Bastien Nocera <bnocera>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: berrange, bnocera, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-02 02:19:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bastien Nocera 2009-09-18 18:41:14 UTC
"vinagre --gtk-vnc-debug" outputs everything on the same line.

Comment 1 Bastien Nocera 2009-09-18 18:44:15 UTC
Actually a bug in vinagre, as "./gvncviewer --gtk-vnc-debug" seems to work fine.

Comment 2 Daniel Berrangé 2009-09-21 09:52:50 UTC
That's rather wierd - i've wonder how vinagre could be able to break the 'g_debug' function which always automatically appends a newline AFAIK. FYI, gtk-vnc outputs all its debugging using:

#define GVNC_DEBUG(fmt, ...) do { if (G_UNLIKELY(debug_enabled)) g_debug(fmt, ## __VA_ARGS__); } while (0)


and its 'fmt' messages never contain a newline, since glib always appends one

Comment 3 Matthias Clasen 2009-10-02 02:19:46 UTC
Works fine here, with vinagre-2.28.0.1-1.fc12. 

Probably fixed by: 

83084e901b8172ccdd6faeb341650f9dd3545d9e
Adapt debug messages to the new gtk-vnc format