Bug 524340

Summary: suggested patch for dot cursor issue
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: tigervncAssignee: Adam Tkac <atkac>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: atkac, ovasik
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.0.0-3.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-27 02:34:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
patch to set the default desktop cursor based on option none

Description Tom Horsley 2009-09-18 23:46:12 EDT
Created attachment 361738 [details]
patch to set the default desktop cursor based on option

Description of problem:

When using vnc to display a KVM console screen, none of the logic related
to the UseLocalCursor or DotWhenNoCursor options ever seems to be executed,
instead the DesktopWindow constructor sets the default cursor to dotCursor
and that's just the way it stays forever, providing a constant visual
irritant.

This suggested patch makes the default cursor be noCursor based on the
DotWhenNoCursor option in the constructor, which certainly seems to me
like it would be less irritating when using vnc to display a KVM console.
Perhaps there should be a completely separate option for the default cursor
rather than overloading the existing option?

Version-Release number of selected component (if applicable):
tigervnc-0.0.91-0.12.fc11

How reproducible:
The annoying dot is always around.

Steps to Reproduce:
1.start virtual machine
2.run vncviewer to connect to console
3.
  
Actual results:
irritating dot

Expected results:
just the virtual machines mouse pointer, no extra dot

Additional info:
Comment 1 Tom Horsley 2009-09-19 09:24:23 EDT
By the way, I went ahead and built from the source rpm with this patch,
and it works like a champ for me - no more irritating dot.

I did notice, however, that I get errors during rpmbuild -bp with
a patch saying it was already applied or reversed. I ignored it
since all I wanted to get built was vncviewer, and that patch was
I think over in the server directory somewhere:

+ patch -p1 -b --suffix .vnc
patching file configure.ac
Hunk #1 succeeded at 29 with fuzz 2.
patching file hw/Makefile.am
patching file mi/miinitext.c
+ echo 'Patch #10 (tigervnc10-xorg-rh514528.patch):'
Patch #10 (tigervnc10-xorg-rh514528.patch):
+ /bin/cat /zooty/build/rpmbuild/SOURCES/tigervnc10-xorg-rh514528.patch
+ /usr/bin/patch -s -p1 -b --suffix .rh514528 --fuzz=0
Reversed (or previously applied) patch detected!  Assume -R? [n]
Comment 2 Adam Tkac 2009-10-07 10:21:39 EDT
(In reply to comment #1)
> By the way, I went ahead and built from the source rpm with this patch,
> and it works like a champ for me - no more irritating dot.
> 
> I did notice, however, that I get errors during rpmbuild -bp with
> a patch saying it was already applied or reversed. I ignored it
> since all I wanted to get built was vncviewer, and that patch was
> I think over in the server directory somewhere:
> 
> + patch -p1 -b --suffix .vnc
> patching file configure.ac
> Hunk #1 succeeded at 29 with fuzz 2.
> patching file hw/Makefile.am
> patching file mi/miinitext.c
> + echo 'Patch #10 (tigervnc10-xorg-rh514528.patch):'
> Patch #10 (tigervnc10-xorg-rh514528.patch):
> + /bin/cat /zooty/build/rpmbuild/SOURCES/tigervnc10-xorg-rh514528.patch
> + /usr/bin/patch -s -p1 -b --suffix .rh514528 --fuzz=0
> Reversed (or previously applied) patch detected!  Assume -R? [n]  

That patch was for X.Org code and now is not needed because it was included to X.Org sources.

I wonder if your patch solves your issue, it seems incomplete for me. I created improved patch and sent it to review: http://www.mail-archive.com/tigervnc-devel@lists.sourceforge.net/msg00412.html.
Comment 3 Tom Horsley 2009-10-07 10:54:36 EDT
When I built with my patch it certainly solved my problem, but I could easily
believe it wouldn't be the right thing to do all the time. What I noticed
when debugging was that vncviewer never went through any of the logic that
was deciding what to do with a cursor (I guess because the way the KVM
emulator works it never even sends any of the cursor opcodes?). All my
patch did was fix the cursor created by default in the constructor, which
was the one always used during the vnc session.
Comment 4 Fedora Update System 2009-10-08 10:29:15 EDT
tigervnc-1.0.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tigervnc-1.0.0-1.fc11
Comment 5 Fedora Update System 2009-10-13 21:37:12 EDT
tigervnc-1.0.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10416
Comment 6 Fedora Update System 2009-10-27 02:33:46 EDT
tigervnc-1.0.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-11-16 09:56:19 EST
tigervnc-1.0.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/tigervnc-1.0.0-3.fc12
Comment 8 Fedora Update System 2009-12-01 23:43:47 EST
tigervnc-1.0.0-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.