Bug 524353

Summary: Can't prompt connection to existing hidden wireless network
Product: [Fedora] Fedora Reporter: Michael Young <m.a.young>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: bugzilla, dcbw
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-23 17:38:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Michael Young 2009-09-19 11:31:39 UTC
I regularly connect to a hidden wireless network. This is set up as an automatic connection but can take a very long time to connect without prompting. Hence I normally try to make the connection manually by selecting "Connect to Hidden Wireless Network ..." from the drop down menu from the icon and selecting the Connection from the list in the subsequent dialog box. Then I used to be able to select the Connect button, however recently this button has remained greyed out so I can no longer use this method.
I wonder if this is related to Password length checking, which might be incorrectly disabling the Connect button in this case because there is no password in the dialog box.

Comment 1 Mario Eckl 2009-10-23 07:46:23 UTC
I have the same problem:

I use NetworkManager to connect to a hidden wireless network (WPA2 security).

Under Fedora 11 the connection was established without a problem.

Updated from Fedora 11 to Fedora 12 Beta (upgrade with DVD). NetworkManager does not autoconnect to the hidden network. When I manually select "Connect to Hidden Wireless Network ..." and select the connection profile from the list, all GUI elements except the "Cancel" Button are greyed out.

I can provide additional information (hardware specs or screenshots) if needed.

Comment 2 Dan Williams 2009-10-23 17:38:04 UTC
Fixed in http://koji.fedoraproject.org/koji/taskinfo?taskID=1762133, which was pulled into Fedora 12 right after the beta went out.  If you 'yum update NetworkManager*', it should give you that build, and it should fix your problem.