Bug 524396

Summary: dovecot.spec changes
Product: [Fedora] Fedora Reporter: Florian La Roche <florian.laroche>
Component: dovecotAssignee: Michal Hlavinka <mhlavink>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: mhlavink
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-30 13:41:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Florian La Roche 2009-09-19 19:42:06 UTC
Description of problem:

The current Fedora dovecot.spec file has a typo: _initddir instead of
_initrddir

Also for a proper rebuild the sources require pkgconfig, so adding
a "BuildRequires: pkgconfig" sould be done.

Also dovecot could use libcap if a "BuildRequires: libcap-devel" is
added.

regards,

Florian La Roche


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Hlavinka 2009-09-29 14:52:28 UTC
(In reply to comment #0)
> The current Fedora dovecot.spec file has a typo: _initddir instead of
> _initrddir

from https://fedoraproject.org/wiki/Packaging/SysVInitScript

Initscripts on the filesystem
-----------------------------
Packages with SysV-style initscripts must put any them into /etc/rc.d/init.d. A rpm macro exists for this directory, %_initddir. Note: The %_initddir macro does not exist on Fedora 9 or older releases, or on RHEL 5 or older. For those releases, you should use the deprecated %_initrddir macro.

> Also for a proper rebuild the sources require pkgconfig, so adding
> a "BuildRequires: pkgconfig" sould be done.

pkgconfig is not required by building itself but some '*-devel' sub-packages used for building require it. These packages usually requires pkgconfig, so it's not needed to have it as buildrequire.

dovecot buildrequires openssl-devel which requires pkgconfig

> Also dovecot could use libcap if a "BuildRequires: libcap-devel" is
> added.

thanks for pointing this out, I'll add libcap in BuildRequires

Comment 2 Florian La Roche 2009-09-29 15:04:54 UTC
_initddir <-> _initrddir: You mix both macros, so you should choose about one.
Extra points to still support RHEL5 builds...

Also for libcap there should then be selinux support added...

regards,

Florian La Roche

Comment 3 Michal Hlavinka 2009-09-30 13:41:43 UTC
> Also for libcap there should then be selinux support added...

I've already asked mgrepl for required changes in selinux policy

> _initddir <-> _initrddir:

fixed

because selinux is changed in selinux-policy package and mixture of _initddir <-> _initrddir brings no real problem, I've just committed changes without building new package.