This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 524417

Summary: Anaconda: /sbin/loader crash on kickstart installation
Product: [Fedora] Fedora Reporter: Lorenzo Villani <lorenzo>
Component: anacondaAssignee: Radek Vykydal <rvykydal>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: awilliam, jvonau3, rvykydal, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: anaconda-12.37-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-13 13:15:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    

Description Lorenzo Villani 2009-09-19 19:07:12 EDT
Description of problem: it seems that, this time, I can't install Fedora rawhide because /sbin/loader crashes after NetworkManager is launched. The weird thing is that this happens only when I specify a full path to a kickstart file on the boot prompt. It doesn't crash after NetworkManager if I install without passing a kickstart file on the command line.


Version-Release number of selected component (if applicable): 12.26


How reproducible: always


Steps to Reproduce:
1. Download today's boot.iso (x86_64) from a rawhide development tree mirror (it should contain anaconda 12.26)
2. Put it on a USB pendrive using livecd-iso-to-disk
3. Boot the USB pendrive then edit the first entry to add ks=http://arbiter.fedorapeople.org/fedora.ks
4. Make sure you have one ethernet card, /sbin/loader running NetworkManager
5. Watch it die with a backtrace immediately after hiding the "NetworkManager is configuring eth0..." dialog.
  

Additional info:
Screenshot of the backtrace (too tired to copy it here)
- http://img11.imageshack.us/img11/5462/63141252.jpg
Comment 1 Radek Vykydal 2009-09-21 08:27:35 EDT
$ eu-addr2line -e usr/lib/debug/usr/lib/anaconda-runtime/loader/loader.debug
0x40782e
/usr/src/debug/anaconda-12.26/loader/loader.c:1725
0x418098
/usr/src/debug/anaconda-12.26/loader/urlinstall.c:118
0x408e11
/usr/src/debug/anaconda-12.26/loader/loader.c:1578
Comment 2 Lorenzo Villani 2009-09-23 16:10:21 EDT
JFYI: This happens on another computer with a different ethernet card. I guess this is not an hardware problem?
Comment 3 Adam Williamson 2009-09-25 11:51:52 EDT
note to self to add this to common bugs if it's not fixed for beta release...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Radek Vykydal 2009-09-29 07:05:36 EDT
Do we support using livecd-iso-to-disk with boot.iso - isn't it only for livecd images?

Nevertheless, this bug can be reproduced also this (hardly ever used I think) way:
- using pxe
- adding stage2= boot parameter with value not parseable as http or ftp url
- using ks with url -url command

I am working on patch.
Comment 5 Adam Williamson 2009-09-29 11:59:08 EDT
"Do we support using livecd-iso-to-disk with boot.iso - isn't it only for livecd
images?"

Hmm - install.img is intended as an equivalent of boot.iso that can be dd'ed straight onto a USB stick, isn't it? If so, you're right, this is pretty much unsupported procedure.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Lorenzo Villani 2009-10-02 12:26:41 EDT
By using livecd-iso-to-disk I basically get only the kernel and the initrd, which should be the same as CentOS "netinstall" iso. Never tried to dd the install.img on a USB stick though.
Comment 7 Jerry Vonau 2009-10-04 17:04:25 EDT
(In reply to comment #5)
> "Do we support using livecd-iso-to-disk with boot.iso - isn't it only for
> livecd
> images?"
> 
> Hmm - install.img is intended as an equivalent of boot.iso that can be dd'ed
> straight onto a USB stick, isn't it? If so, you're right, this is pretty much
> unsupported procedure.
> 


No, install.img is part anaconda's filesystem. You would want to dd the boot.iso to an usb stick.
Comment 8 Lorenzo Villani 2009-10-11 14:42:26 EDT
Found the source of all problems. I tried again with today's boot.iso image (anaconda 12.35). This time I dd'ed the boot.iso image with no success. Anaconda crashed again. I decided to give a look at the logs while it tried to initialize the kickstart procedure and saw this:

http://img410.imageshack.us/img410/4650/img0249l.jpg
(See the last two lines)

So I tried to remove stage2=hd:LABEL:"Fedora" from grub command line and guess what? Anaconda started the installation as usual (by downloading install.img from the server).

Just my $0.02: I think it's better to add a "Do Kickstart installation" option in grub menu without stage2=hd:LABEL:"Fedora"

Hope this helps.
Comment 9 Jerry Vonau 2009-10-11 19:32:58 EDT
The usual method with the boot.iso is to use the install.img that is on the cdrom.
You could try to edit the bootloader to use 
stage2=hd:LABEL:Fedora:/images/install.img

That should prevent the downloading of stage2 from the net and use the one on the usb key. Think this is the same issue that I outlined at:

https://bugzilla.redhat.com/show_bug.cgi?id=524524
Comment 10 Radek Vykydal 2009-10-12 09:47:33 EDT
The segfault should be fixed in anaconda-12.37-1.
Comment 11 Lorenzo Villani 2009-10-13 12:54:07 EDT
(In reply to comment #9)
> [snip]
> You could try to edit the bootloader to use 
> stage2=hd:LABEL:Fedora:/images/install.img

With that change it works.


(In reply to comment #10)
> The segfault should be fixed in anaconda-12.37-1.  

Confirmed as fixed.
Comment 12 Radek Vykydal 2009-10-13 13:15:50 EDT
Thanks for the bug report, comments, and testing.