Bug 526021

Summary: f12 beta failed to boot on ppc platform after autopart and encrypted installation
Product: [Fedora] Fedora Reporter: Liam Li <lili>
Component: yabootAssignee: David Woodhouse <dwmw2>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dcantrell, dwmw2, jlaska, pavan.naregundi, pnasrat, rrakus, tony, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: ppc64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-22 00:57:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
log
none
Partition screenshot
none
Boot.log (with yaboot.debug from yaboot-1.3.14-20.fc12)
none
Installer log files.tgz (/tmp/*log*)
none
Boot.log (with yaboot.debug from yaboot-1.3.14-21.fc12) none

Description Liam Li 2009-09-28 07:52:19 EDT
Description of problem:
install f12 beta on ppc64 platform, during partition,select autopart and encrypt,other settings are default,after reboot,system can not correctly boot up

Version-Release number of selected component (if applicable):
anaconda 12.30

How reproducible:
100%
Comment 1 Chris Lumens 2009-09-28 09:47:58 EDT
Please attach /tmp/program.log to this bug report.
Comment 2 Liam Li 2009-09-30 02:29:45 EDT
I can not switch to terminal to get program.log due to bug:526158
Comment 3 Chris Lumens 2009-09-30 11:50:24 EDT
If you switch around between terminals, I believe you can get the font to look right again.  At least, I was able to do this on a ppc64 machine the other day.  If not, you can at least type blindly.
Comment 4 James Laska 2009-10-01 15:34:01 EDT
I have a sneaking suspicion that this is related to the boot failures we've had on ppc since F-11.  I've not yet pinned them down, but bug#523754 seems to have the most traction on the issue so far.
Comment 5 Liam Li 2009-10-09 01:32:53 EDT
Created attachment 364196 [details]
log


(In reply to comment #1)
> Please attach /tmp/program.log to this bug report. 

this is install log
Comment 6 James Laska 2009-10-09 09:51:35 EDT
Sorry Liam to ask for more details.  There is a very similar bug#523754 that caused install success, but resulted in boot failure on ppc.

A fix for this issue was confirmed by mbanas (see https://bugzilla.redhat.com/show_bug.cgi?id=523754#c34).  Can you confirm whether this issue is similar to the defect reported in bug#523754?  Also, does this problem still occur on the packages fixed in that bug (parted-1.9.0-16)?
Comment 7 Liam Li 2009-10-12 03:50:01 EDT
I tested on rawhide 20091009,parted 1.9.0, the result is the same. It seems the bug 523754 was already fixed on rawhide 200908 according to comments 39.
Comment 8 James Laska 2009-10-12 14:22:08 EDT
Adding Tony Breeds and Pavan Naregundi to the cc list.  This is similar but different from bug#523754.  The use case here involves using the anaconda recommended default partitioning scheme, but with encryption.  The resulting system in unable to boot.
Comment 9 Tony Breeds 2009-10-12 23:09:40 EDT
So looking at the storage.log (for the first time) it looks like autopartition created:

sda1 prep
sda2 ext3 /boot
sda3 encrypted LVM containing root and swap

Is that right?

How exactly does it fail?  Can we get a dump of the boot logs?
Can I get the output of: fdisk -l /dev/sda

The yaboot RPM at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1742981

contains a new /usr/lib/yaboot.debug, it'd be great if we could use that binary.
Comment 10 James Laska 2009-10-13 11:08:26 EDT
(In reply to comment #9)
> So looking at the storage.log (for the first time) it looks like autopartition
> created:
> 
> sda1 prep
> sda2 ext3 /boot
> sda3 encrypted LVM containing root and swap
> 
> Is that right?

That's right.  I'm seeing the same issue here on a IBM Power5 system doing autopart + encrypted install (see attached screenshot of partition detail screen)

> How exactly does it fail?  Can we get a dump of the boot logs?

See attached files (anaconda.log, storage.log, program.log, syslog, boot.log)

> Can I get the output of: fdisk -l /dev/sda

sh-4.0# fdisk  -l /dev/sda

Disk /dev/sda: 36.4 GB, 36401479680 bytes
128 heads, 32 sectors/track, 17357 cylinders
Units = cylinders of 4096 * 512 = 2097152 bytes
Disk identifier: 0x0eb50900

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1           3        4096   41  PPC PReP Boot
Partition 1 does not end on cylinder boundary.
/dev/sda2               3         103      204800   83  Linux
Partition 2 does not end on cylinder boundary.
/dev/sda3             103       17356    35334885   83  Linux
Partition 3 does not end on cylinder boundary.

> The yaboot RPM at:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1742981
> 
> contains a new /usr/lib/yaboot.debug, it'd be great if we could use that
> binary.  

I installed this package and reran: # mkofboot -i /usr/lib/yaboot/yaboot.debug 

mkofboot: Overwrite contents of /dev/sda1 with /usr/lib/yaboot/yaboot.debug? [y/N] y

See attached boot.log
Comment 11 James Laska 2009-10-13 11:09:29 EDT
Created attachment 364610 [details]
Partition screenshot
Comment 12 James Laska 2009-10-13 11:11:09 EDT
Created attachment 364611 [details]
Boot.log (with yaboot.debug from yaboot-1.3.14-20.fc12)
Comment 13 James Laska 2009-10-13 11:11:35 EDT
Created attachment 364612 [details]
Installer log files.tgz (/tmp/*log*)
Comment 14 Tony Breeds 2009-10-13 18:56:45 EDT
(In reply to comment #10)

<snip> all good information

> See attached boot.log  

Thanks James,

Please try the yaboot.debug from:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=1745433

to see it the problem is resolved?
Comment 15 James Laska 2009-10-16 13:21:40 EDT
Created attachment 365078 [details]
Boot.log (with yaboot.debug from yaboot-1.3.14-21.fc12)

(In reply to comment #14)
> (In reply to comment #10)
> 
> <snip> all good information
> 
> > See attached boot.log  
> 
> Thanks James,
> 
> Please try the yaboot.debug from:
>   http://koji.fedoraproject.org/koji/taskinfo?taskID=1745433
> 
> to see it the problem is resolved?  

Thanks Tony.  You know, I believe that may have solved the problem.  I installed with autopart+encryption.  After install, prior to reboot, I:
 1. installed yaboot-1.3.14-21.fc12
 2. updated yaboot.conf to use yaboot.debug
 3. re-ran mkofboot

The system gets to yaboot, and is able to proceed to booting the Fedora system.  It fails to boot with what appears to be a dracut problem locating the root device.  I don't know if that's a different issue or related at this point.  I'm attaching the boot log, and will continue testing ...
Comment 16 Tony Breeds 2009-10-18 21:35:32 EDT
(In reply to comment #15)
 
> Thanks Tony.  You know, I believe that may have solved the problem.  I
> installed with autopart+encryption.  

Great!

Thanks for you help testing this James.  I've included this change in the yaboot-1.3.14-22 build, which shoudl be in updates-testing RSN

> The system gets to yaboot, and is able to proceed to booting the Fedora system.
>  It fails to boot with what appears to be a dracut problem locating the root
> device.  I don't know if that's a different issue or related at this point. 
> I'm attaching the boot log, and will continue testing ...  

From the logs:
---
dracut: Starting plymouth daemon
plymouthd: ply-console.c:352: ply_console_set_active_vt: Assertion `vt_number > 0' failed.
---

Looks like dracut/plymouth hasn't detected that your are not on a Virtual Console, and it can't then prompt for pass phrases etc etc

Just a guess.
Comment 17 Fedora Update System 2009-10-18 21:36:19 EDT
yaboot-1.3.14-22.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/yaboot-1.3.14-22.fc12
Comment 18 Jesse Keating 2009-10-21 19:25:17 EDT
That build has been tagged for F12-final.  Not sure if that's enough to fix this bug or not.
Comment 19 Tony Breeds 2009-10-21 22:20:16 EDT
I believe that the 1.3.14-22 RPM is adequate to close this bug.  There is more yaboot can do but I don't believe we need to for the F12 release.