Bug 526352

Summary: typo in rhn-satellite-5-upgrade-scenario-1b.txt: "dppassword" -> "dbpassword"
Product: Red Hat Satellite 5 Reporter: Jan Hutař <jhutar>
Component: UpgradesAssignee: Milan Zázrivec <mzazrivec>
Status: CLOSED CURRENTRELEASE QA Contact: Tomas Lestach <tlestach>
Severity: low Docs Contact:
Priority: low    
Version: 530CC: cperry, msuchy, tlestach
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: rhn-upgrade-5.4.0.5-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-10-28 14:58:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 608757    

Description Jan Hutař 2009-09-29 22:48:49 UTC
Description of problem:
There is a typo in second step in rhn-satellite-5-upgrade-scenario-1b.txt.


Version-Release number of selected component (if applicable):
rhn-upgrade-5.3.0.24-1.el4sat


How reproducible:
always


Steps to Reproduce:
1. see rhn-satellite-5-upgrade-scenario-1b.txt


Actual results:
         You will need connection string to your database for next steps. To
         find out an estimate on required free space in temporary tablespace
         (the estimate computation may take several minutes):

           cd /etc/sysconfig/rhn/satellite-upgrade
           sqlplus -S dbusername/dppassword@dbSID @satellite-temp_tbs-estimate.sql

         In case you use external database, consult your DBA for further actions.


Expected results:
-> sqlplus -S dbusername/dbpassword@dbSID @satellite-temp_tbs-estimate.sql
                         ^^^^^^^^^^

Comment 1 Milan Zázrivec 2010-08-26 11:36:08 UTC
satellite.git: 9dcee98312738759d2847c7a3e63a5d67c8e60f2

Comment 2 Tomas Lestach 2010-10-05 16:29:37 UTC
testing rhn-upgrade-5.4.0.7-1.el5sat

# grep -r sqlplus /etc/sysconfig/rhn/satellite-upgrade/satellite-upgrade.txt 
    sqlplus -S $(spacewalk-cfg-get default_db) @satellite-temp_tbs-estimate.sql
    sqlplus -S $(spacewalk-cfg-get default_db) @satellite-schema-time.sql

Looks like the dummy connect string (dbusername/dppassword@dbSID) was completely replaced by $(spacewalk-cfg-get default_db) what is much cleaner solution -> VERIFIED

Comment 3 Miroslav Suchý 2010-10-22 14:12:42 UTC
This paragraph now state:
- When upgrading from Satellite 5.2 and earlier, you may need temporary
tablespace larger than 1 GB. To find out an estimate on space required
in temporary tablespace, execute the following (the estimate computation
may take several minutes):

    cd /etc/sysconfig/rhn/satellite-upgrade
    sqlplus -S $(spacewalk-cfg-get default_db) @satellite-temp_tbs-estimate.sql

Comment 4 Clifford Perry 2010-10-28 14:53:25 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford