Bug 526362

Summary: RPM errors with old packages
Product: [Fedora] Fedora Reporter: Juan Urroa <observer1>
Component: rpmAssignee: Panu Matilainen <pmatilai>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: ffesti, jnovy, pmatilai
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-06 05:27:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Juan Urroa 2009-09-29 23:50:06 UTC
RPM Gives md5 errors in some files when using and old version of rpm on new rpm files.

Using fedora 8 or 9 rpm with a source rpm for fedora 11 gives a md5 error for the files inside the rpm 

rpm -K shows no problem on the file

I think the rpm algorithms for md5 should be the same across releases no matter if the distro is already archived.

Comment 1 Panu Matilainen 2009-10-06 05:27:15 UTC
Fedora 11 uses sha256 for file checksums, but the older rpm versions dont support that. The actual bug is that rpm doesn't verify rpmlib() dependencies on src.rpm installation but Fedora 8 and 9 are EOL so cant fix.