This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 526881

Summary: ibus-anthy backtrace is reported by the latest abrt
Product: [Fedora] Fedora Reporter: Ales Zelinka <azelinka>
Component: ibus-anthyAssignee: fujiwara <tfujiwar>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, dwmw2, i18n-bugs, petersen, phuang, tagoh, tfujiwar
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: abrt_hash:fc1f2891
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-23 13:46:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
File: backtrace
none
Patch for engine/engine.py none

Description Ales Zelinka 2009-10-02 05:53:15 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
As recomended in bz526222, I've replaced scim with ibus (only ibus+devs and ibus-anthy pkgs installed). 
Then I've aded "Japanese anthy" via ibus-setup and made ibus the default input method using im-chooser. 
Both im-chooser and ibus-setup generates this error, probably because it starts ibus-server.


Additional information
======


Attached files
----
backtrace

cmdline
-----
python /usr/share/ibus-anthy/engine/main.py --ibus 


component
-----
ibus-anthy


executable
-----
/usr/share/ibus-anthy/engine/main.py


kernel
-----
2.6.31.1-56.fc12.x86_64


package
-----
ibus-anthy-1.2.0.20090917-1.fc12


uuid
-----
fc1f2891
Comment 1 Ales Zelinka 2009-10-02 05:53:18 EDT
Created attachment 363452 [details]
File: backtrace
Comment 2 fujiwara 2009-10-05 00:55:12 EDT
I could reproduce this error when I launch ibus-setup.
But ibus-anthy doesn't crash with this error so I don't think the error is critical at the moment.

When ibus sets section='panel', name='custom_font', value='Sans 10', ibus-gconf sends "ValueChanged" signal and ibus-daemon sends "value-changed" signal and ibus-anthy receive the signal.

Since the setting is used for ibus only, ibus-anthy just can ignore the setting.
So the error is not harm.
I'll fix the error for f13 to ignore the signal in case of section='panel'.
Comment 3 fujiwara 2009-10-05 01:28:52 EDT
Created attachment 363637 [details]
Patch for engine/engine.py

Ignore the setting when section == 'panel'.
Comment 5 Jens Petersen 2009-10-22 02:18:07 EDT
Can we have an update for F12?
Comment 6 Jens Petersen 2009-10-22 02:57:30 EDT
Easily reproduced for me by restarting ibus from it Restart
command in ibus command menu:

 Right click on ibus applet -> Restart
Comment 7 Jens Petersen 2009-10-22 03:39:33 EDT
and maybe start ibus-setup?

I think we should try to fix this crasher for f12-final.
Comment 8 fujiwara 2009-10-22 03:58:13 EDT
The following link is the test build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1762448

Would anyone confirm the fix?
I cannot reproduce any crashes actually.
Comment 9 fujiwara 2009-10-23 00:35:01 EDT
When I installed rawhide with upgrade install, 5 abrt packages only are installed:

abrt-gui, abrt, abrt-addon-kerneloops, abrt-plugin-kerneloopsreporter, abrt-libs

Ant it doesn't detect any errors in my env.

After I install all abrt packages with 'yum install abrt\*' and restart abrtd/abrt-applet, I could reproduce this problem.

It seems abrt forcibly get the crash. When I kill abrt-applet, the problem is not reproduced.

Since the error dialog is visible, probably it's good to fix this in f12.
abrt is not integrated in f11 by default.
Also I confirmed my fix is ok for this bug.
Comment 11 fujiwara 2009-10-23 02:51:27 EDT
https://fedorahosted.org/rel-eng/ticket/2665
Comment 12 Adam Williamson 2009-10-23 13:46:52 EDT
This was discussed at today's blocker review meeting. As the bug looks to be fixed and the fixed build tagged, closing. Alex, please re-open if you still hit trouble with ibus-anthy-1.2.0.20090917-2.fc12 or later.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers