Bug 529258

Summary: upgrade should remove duplicate and obsolete schema from 99user.ldif
Product: [Retired] 389 Reporter: Rich Megginson <rmeggins>
Component: Install/UninstallAssignee: Nathan Kinder <nkinder>
Status: CLOSED CURRENTRELEASE QA Contact: Viktor Ashirov <vashirov>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.3.0CC: jgalipea
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-12-07 16:41:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 434914, 519216, 531879    
Attachments:
Description Flags
Proposed Patch none

Description Rich Megginson 2009-10-15 19:24:59 UTC
Due to bug 474254, the 99user.ldif may contain many schema definitions from the standard schema files, some of which are now obsolete.  Upgrade must remove duplicate and obsolete schema from 99user.ldif.

Comment 1 Nathan Kinder 2009-10-29 01:24:15 UTC
Created attachment 366526 [details]
Proposed Patch

Comment 2 Nathan Kinder 2009-10-29 02:29:27 UTC
Pushed patch from comment#1 to master (with minor typo correction in a comment).

Counting objects: 15, done.
Delta compression using 2 threads.
Compressing objects: 100% (7/7), done.
Writing objects: 100% (8/8), 2.75 KiB, done.
Total 8 (delta 5), reused 0 (delta 0)
To ssh://git.fedorahosted.org/git/389/ds.git
   de63856..f4eae7f  master -> master

Comment 3 Jenny Severance 2010-06-07 16:27:21 UTC
verified - RHEL 4

version:
redhat-ds-base-8.2.0-2010060704.el4dsrv

1. installed DS 8.1
2. added custom schema and duplicate defined schema from other schema file to 99user.ldif
3. upgraded to DS 8.2

After upgrade only custom defined schema existed in 99user.ldif.