Bug 529355

Summary: gnome-terminal (+ssh) lockup when remote server dies
Product: [Fedora] Fedora Reporter: Jan "Yenya" Kasprzak <kas>
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: behdad
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-06-28 11:02:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jan "Yenya" Kasprzak 2009-10-16 06:34:54 EDT
Description of problem:

I run a gnome session with lots of gnome-terminal windows (using factory, so all of them are handled by a single process. Some of the terminals are running ssh sessions to various remote servers. From time to time, when some remote server crashes or the network connection to it becomes dead, the whole gnome-terminal process locks up, making all the other windows unresponsive - they are not even redrawing their contents in response to the X Expose event. When the network connection is restored (or the crashed server gets rebooted and the established connections are reset by peer), the gnome-terminal process refreshes all its windows and I am able to work again.

Version-Release number of selected component (if applicable):
gnome-terminal-2.26.3.1-1.fc11.x86_64

How reproducible:
sometimes, not sure how to reproduce

Additional info:
I have tried to reproduce the problem using

1. open another gnome-terminal window
2. run "ssh someserver" in it
3. in a different window, run "iptables -A INPUT -s someserver -j DROP"
4. try to enter or paste some text to the ssh window

but I have not been able to reproduce it this way. So the bug is probably more subtle than that (maybe the connection dying right in the middle of the escape sequence or something like that).
Comment 1 Bug Zapper 2010-04-28 06:51:17 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2010-06-28 11:02:28 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.