Bug 529711

Summary: qemu: could not open serial device 'pty'
Product: [Fedora] Fedora Reporter: Gianluca Varisco <gvarisco>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: berrange, clalance, crobinso, itamar, jforbes, keqin.hong, lists.kho, markmc, nobody, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-23 09:56:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Gianluca Varisco 2009-10-19 11:47:14 EDT
Description of problem:

When I try to start a x86_64 KVM guest on my box I obtain this backtrace from virt-manager:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 571, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 664, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 293, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: qemu: could not open serial device 'pty': No child processes

/var/log/messages says:

Oct 19 17:43:27 gvarisco libvirtd: 17:43:27.967: error : qemudReadLogOutput:915 : internal error Process exited while reading console log output
Oct 19 17:43:27 gvarisco libvirtd: 17:43:27.967: error : qemudWaitForMonitor:1203 : internal error unable to start guest: qemu: could not open serial device 'pty': No child processes#012

How can I fix this issue?

Please let me know if you need further details.


Version-Release number of selected component (if applicable):

qemu-kvm-0.11.0-6.fc12.x86_64
kernel-2.6.31.1-56.fc12.x86_64
libvirt-0.7.1-11.fc12.x86_64
Comment 1 John Hong 2009-10-20 22:32:48 EDT
It's better to put your system info here, like CPU.
Besides, you may use "selinuxenabled ; echo $?" to check if selinux is enabled. Status 0 means selinux is enabled, otherwise not.
Comment 2 Martin Kho 2009-10-21 16:34:48 EDT
Hi,

I have exact the same error after an update yesterday. Before this update F12Beta - released yesterday! :-) - was running fine.

1. My smolt profile can be found here [1]
2. I'm running selinux in permissive mode, so I get AVC-messages. Actually I get tree messages, see [2]


[1] http://www.smolts.org/client/show/pub_18cdf89a-040b-44e0-9859-907a28d290f7
[2] BZ: #530189, #530191, and #530192

Hope this info helps.

Martin Kho
Comment 3 Martin Kho 2009-10-21 17:08:38 EDT
[SOLVED]

Hi,

Danial Walsh has responded on bug report: #530192: He said:

"This is a leaked file descriptor from qemu which should be changed.

But the error is caused by a bad entry in your /etc/fstab, that was introduced
in F11.

Your /etc/fstab devpts line should look like

grep devpts /etc/fstab 
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0

Otherwise svirt through glibc will attempt to fix the labeling of the pty. 
Fixing this and executing mount -a should fix the problem."

This also fixed the original issue.

Martin Kho
Comment 4 Mark McLoughlin 2009-10-23 06:23:47 EDT
Thanks for the hints Martin

Gianluca, could you check your devpts entry in /etc/fstab?
Comment 5 Gianluca Varisco 2009-10-23 07:38:50 EDT
Mark, I confirm Martin's hint fixed my issue related to devpts.

Many thanks to both of you! ;-)

Ciao,

Gianluca
Comment 6 Mark McLoughlin 2009-10-23 09:56:24 EDT
Thanks Gianluca

*** This bug has been marked as a duplicate of bug 515521 ***