Bug 530306

Summary: Preupgrade doesn't work if computer doesn't have CD/DVD drive
Product: [Fedora] Fedora Reporter: Dululu <dululu>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-26 03:50:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Dululu 2009-10-22 05:44:38 EDT
Description of problem:

Using pre-upgrade to upgrade from Fedora 11 (latest updates as at 21/10/2009) to rawhide (21/10/2009) on a computer which doesn't have a CD/DVD rom drive.

Booting the "Upgrade to Rawhide" Grub menu option, anaconda stops with the message "Unable to find any devices of the type needed for this installation type. Would you like to manually select your driver or use a driver disk?" with the options "Select driver / Use a driver disk / Back"

On the other VT (I think VT 3) the last messages displayed are 
" INFO : setting up kickstart"
" ERROR : got to setupCdrom without a CD device"
" INFO : setting language to en_US.UTF-8"


Version-Release number of selected component (if applicable):
preupgrade-1.1.0-1.fc11.noarch
rawhide (tested on 19/10/2009 and 21/10/2009)

How reproducible:

Always

Steps to Reproduce:
1. Run preupgrade to upgrade F11 to rawhide on desktop without CD / DVD rom
2. Reboot computer and select "Upgrade to Rawhide" kernel
3.
  
Actual results:

Upgrade fails seeking device driver

Expected results:

Upgrade succeeds

Additional info:

I'm not sure if this is a preupgrade bug or an anaconda bug, filed against preupgrade because that's what I used and I don't have the hardware or time to run tests against anaconda by itself (without using preupgrade).
Comment 1 Dululu 2009-10-26 03:50:03 EDT
Wrong error & component - will open under anaconda