Bug 531102

Summary: RFE/PATCH: add verification of .pyc/.pyo files
Product: [Fedora] Fedora Reporter: Dave Malcolm <dmalcolm>
Component: rpmlintAssignee: Ville Skyttä <ville.skytta>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: tmz, ville.skytta, wolfy
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: rpmlint-0.94-1.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 557616 (view as bug list) Environment:
Last Closed: 2010-01-25 18:17:43 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 530636    

Description Dave Malcolm 2009-10-26 17:35:23 EDT
Description of problem:
As part of my towards getting a parallel-installable Python 3 stack into Fedora 13 ( https://fedoraproject.org/wiki/Features/Python3F13 ), I want to make sure that for every packaged .pyc/.pyo file, that:
  - the "magic" ABI value in the header matches that of the Python runtime that it's targetting (it appears to be easy to get this wrong; rpmbuild's postprocessing sets this to the ABI value for /usr/bin/python by default).
  - the timestamp matches the mtime of the corresponding .py file (which is currently not correct for bug 526126)

I've created a new test for rpmlint which can be seen here:
http://dmalcolm.fedorapeople.org/rpmlint/add-tests-for-python-bytecode-files-v2.patch

See this thread:
https://www.zarb.org/pipermail/rpmlint-discuss/2009-October/000775.html
Comment 1 Ville Skyttä 2009-10-27 18:17:42 EDT
Yep, thanks, let's keep the discussion on upstream rpmlint-discuss list.  Assigning to myself here for now though until the outcome of the patch is in Fedora's rpmlint.  (But if you'd prefer to see this bug CLOSED UPSTREAM, just go ahead.)
Comment 2 Dave Malcolm 2009-10-27 18:26:26 EDT
Sorry about this; the reason I opened a bz about this is to add it to my tracker bug for Python 3 in Fedora 13 (bug 530613), to make it easy for me to track the various things that need to happen.

For that reason I'd prefer to keep this bug open until we've got a version of the tests that you're happy with and that are actually in F13's rpmlint rpm (either via adding to upstream rpmlint, or via downstream patching in Fedora).

Hope that's OK.
Comment 3 Dave Malcolm 2009-10-27 18:28:01 EDT
(In reply to comment #2)
> tracker bug for Python 3 in Fedora 13 (bug 530613), to make it easy for me to
(which should have read "bug 530636"; sorry)
Comment 4 Ville Skyttä 2009-11-02 16:45:16 EST
mtime and *.py existence parts of the patch are included in 0.92-1, see upstream list for discussion about the magic bits.
Comment 5 Dave Malcolm 2010-01-25 17:36:33 EST
For reference: from my reading of the 0.93 release:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/log/trunk?
rev=1718&stop_rev=1682&verbose=on

it looks like this test is in 0.93, the upstream commit was:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1687/trunk

so presumably this can be closed out once 0.93 is in rawhide.

Thanks!
Comment 6 Ville Skyttä 2010-01-25 18:17:43 EST
Yep, that's right, it's in 0.93-2 which will hopefully appear in the next Rawhide push.  Thank you.
Comment 7 Fedora Update System 2010-01-25 18:28:47 EST
rpmlint-0.93-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.93-2.fc12
Comment 8 Fedora Update System 2010-01-31 18:23:08 EST
rpmlint-0.94-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.94-1.fc12
Comment 9 Fedora Update System 2010-02-19 19:09:36 EST
rpmlint-0.94-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.