Bug 531649

Summary: Confirming channel merges doesn't display confirmation of package changes
Product: Red Hat Satellite 5 Reporter: Xixi <xdmoon>
Component: WebUIAssignee: Justin Sherrill <jsherril>
Status: CLOSED ERRATA QA Contact: Garik Khachikyan <gkhachik>
Severity: urgent Docs Contact:
Priority: medium    
Version: 530CC: cperry, gkhachik, mkoci, tao, xdmoon
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-20 10:37:36 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 518256    

Description Xixi 2009-10-28 20:55:32 EDT
Description of problem:
After comparing a cloned channel and merging the differences between the two i.e after clicking the confirm button the page is redirected to Cloned Channel -> Packages -> List / Remove.

There's no confirmation messages shown as before, e.g., -
"3 packages added to channel Clone test of Red Hat Enterprise Linux (v. 5 for 32-bit x86). "

"The list of packages associated with this channel has been modified recently.

These changes will not immediately be available to systems which are subscribed to this channel. The changes will become available approximately 10 minutes after they are made. Or, you can commit your changes immediately when you are finished editing this channel."

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

System architecture(s):
RHEL 5 U3 i386 platform

How reproducible:
Always.

Steps to Reproduce:
1. Browse to 'Channels' tab -> 'Manage Software Channels'
2. Click on any of the custom channel (like "Clone of Red Hat Network Tools for RHEL Client v.5 32-bit x86")
3. On the next page, click on 'Packages' tab -> 'Compare'. Click on any of the similar channel from the list and hit 'Compare'
4. On the next page, hit 'Merge Differences' and select 'Make identical to .. ' and hit 'Preview Merge'
5. From the list of packages displayed, select a few and move into the next page
6. Click on Confirm

Actual results:
- After clicking on Confirm the page is redirected to
https://<satellite-fqdn>/rhn/channels/manage/ChannelPackages.do?set_label=packages_for_merge&sync_type=full_sync&view_channel=channel_333&cid=<id> where no confirmation message of package merge is shown.

Expected results:
It should show confirmation as before e.g., 
"3 packages added to channel Clone test of Red Hat Enterprise Linux (v. 5 for 32-bit x86). "

"The list of packages associated with this channel has been modified recently.

These changes will not immediately be available to systems which are subscribed to this channel. The changes will become available approximately 10 minutes after they are made. Or, you can commit your changes immediately when you are finished editing this channel."

Additional info:
This is a cosmetic regression possibly due to perl->java migration of page.
Comment 2 Xixi 2009-10-28 20:59:16 EDT
It looks like the confirmation message is still there but for some reason doesn't display on com/redhat/rhn/frontend/action/channel/manage/ChannelPackagesAction.java - IIRC at one point I clicked on the Back button after confirming the merge and landing at Packages list page, and the message then appeared.

com/redhat/rhn/frontend/action/channel/manage/ChannelPackagesAddConfirmAction.java
...
        if (button.equals(request.getParameter("confirm")) && set.size() > 0) {
            int setSize = set.size();
            addPackages(user, chan, set);
            ActionMessages msg = new ActionMessages();
            String[] actionParams = {setSize + "", chan.getName()};
            msg.add(ActionMessages.GLOBAL_MESSAGE,
                    new ActionMessage("channel.jsp.package.addsuccess",
                            actionParams));
...
Comment 3 Justin Sherrill 2009-11-06 12:42:55 EST
fixed in commit 307f6631b00db283a1d79755d6ccfb973d1e52ee
Comment 4 Justin Sherrill 2009-11-10 13:50:58 EST
fixed in SATELLITE-5.3:  0a7cc1a0a8fd92e1f0d3749d254fd2a5f98dfa37
Comment 5 Garik Khachikyan 2009-11-19 03:45:19 EST
#VERIFIED
Checked the fix with packages:
spacewalk-java-0.5.44-50.el[4,5]sat
spacewalk-java-lib-0.5.44-50.el[4,5]sat
spacewalk-java-config-0.5.44-50.el[4,5]sat
spacewalk-taskomatic-0.5.44-50.el[4,5]sat
spacewalk-moon-0.5.23-29.el[4,5]sat
spacewalk-grail-0.5.23-29.el[4,5]sat
spacewalk-base-minimal-0.5.23-29.el[4,5]sat
spacewalk-cypress-0.5.23-29.el[4,5]sat
spacewalk-html-0.5.23-29.el[4,5]sat
spacewalk-base-0.5.23-29.el[4,5]sat
spacewalk-sniglets-0.5.23-29.el[4,5]sat
spacewalk-pxt-0.5.23-29.el[4,5]sat

Checked against satellite installed with rhel5 and rhel4 (platform: i386).

The message "1 Package(s) have been added and 0 Package(s) have been removed from the channel." is shown and the button "Confirm removal" is there.
Comment 7 errata-xmlrpc 2009-11-20 10:37:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1597.html