Bug 532862

Summary: NetworkManager in fedora 12 rawhide can not make DSL(ADSL) connection
Product: [Fedora] Fedora Reporter: landrew <landrew>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, dcantrell, jlaska, maurizio.antillon, nb, notting, pal666
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-04 22:11:30 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 473303    
Attachments:
Description Flags
output of NetworkManager none

Description landrew 2009-11-03 23:20:23 EST
Created attachment 367401 [details]
output of NetworkManager

Description of problem:
I'm using fedora 12. All the packages are the newest from the repo. The NetworkManager can make LAN connection successfully. But it can not make ADSL connection using pppoe. In the DSL tab, I just entered diaup username and password, all other options are with default value.

Version-Release number of selected component (if applicable):
#rpm -qa|grep NetworkManager
   NetworkManager-pptp-0.7.996-4.git20090921.fc12.i686  
   NetworkManager-gnome-0.7.996-5.git20091021.fc12.i686
   NetworkManager-vpnc-0.7.996-4.git20090921.fc12.i686
   NetworkManager-0.7.996-5.git20091021.fc12.i686
   NetworkManager-glib-0.7.996-5.git20091021.fc12.i686
   NetworkManager-openvpn-0.7.996-4.git20090923.fc12.i686
#rpm -qa|grep ppp
   ppp-2.4.4-13.fc12.i686
kernel:
   kernel-2.6.31.5-96.fc12.i686.PAE
#rpm -qa|grep dbus
   dbus-cxx-doc-0.4.3-1.fc12.noarch
   dbus-1.2.16-8.fc12.i686
   dbus-cxx-0.4.3-1.fc12.i686
   dbus-libs-1.2.16-8.fc12.i686
   dbus-glib-0.82-2.fc12.i686


How reproducible:


Steps to Reproduce:
1. login to gnome desktop
2. edit a ADSL connection entry using pppoe (just enter the username and password)
3. use the entry to connect ISP.
  
Actual results:
NetworManager can not connect my ISP in the end

Expected results:
NetworManager will connect my ISP, and ready for all the desktop network application to be online.

Additional info:
I use the following step to get some log:
# /etc/init.d/NetworkManager stop
# NM_PPP_DEBUG=1 NetworkManager --no-daemon 2>&1 | tee /tmp/nm.log
output on console:
...
NetworkManager: <info>  (eth0): device state change: 8 -> 3 (reason 0)
NetworkManager: <info>  (eth0): deactivating device (reason: 0).
-- Error received: Numerical result out of range
-- Original message: type=0x19 length=56 flags=<REQUEST,ACK> sequence-nr=1257305830 pid=4196082
NetworkManager: <WARN>  check_one_route(): (eth0) error -34 returned from rtnl_route_del(): Sucess

NetworkManager: <info>  Activation (eth0) starting connection 'unicom'
NetworkManager: <info>  (eth0): device state change: 3 -> 4 (reason 0)
NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) started...
NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) starting...
NetworkManager: <info>  (eth0): device state change: 4 -> 5 (reason 0)
NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) successful.
NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) complete.
NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
NetworkManager: <info>  (eth0): device state change: 5 -> 7 (reason 0)
NetworkManager: <info>  Starting pppd connection
NetworkManager: <debug> [1257305824.230001] nm_ppp_manager_start(): Command line: /usr/sbin/pppd nodetach lock nodefaultroute debug user 172078001716@201 plugin rp-pppoe.so nic-eth0 noauth nodeflate usepeerdns mru 1492 mtu 1492 lcp-echo-failure 3 lcp-echo-interval 20 ipparam /org/freedesktop/NetworkManager/PPP/0 plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.3 compiled against pppd 2.4.4
Plugin /usr/lib/pppd/2.4.4/nm-pppd-plugin.so loaded.
** Message: nm-ppp-plugin: (plugin_init): initializing
NetworkManager: <debug> [1257305824.241839] nm_ppp_manager_start(): ppp started with pid 1813
NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP6 Configure Get) scheduled...
** Message: nm-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP6 Configure Get) started...
NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP6 Configure Get) complete.
using channel 2
Using interface ppp0
Connect: ppp0 <--> eth0
** Message: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x5c92c8ac>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0x5c92c8ac>]
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x5c92c8ac>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0x5c92c8ac>]
rcvd [LCP ConfReq id=0x1 <mru 1492> <auth pap> <magic 0x5004b3a>]
sent [LCP ConfAck id=0x1 <mru 1492> <auth pap> <magic 0x5004b3a>]
sent [LCP EchoReq id=0x0 magic=0x5c92c8ac]
** Message: nm-ppp-plugin: (nm_phasechange): status 6 / phase 'authenticate'
** Message: nm-ppp-plugin: (get_credentials): passwd-hook, requesting credentials...
NetworkManager: <WARN>  pppd_timed_out(): Looks like pppd didn't initialize our dbus module
NetworkManager: <info>  (eth0): device state change: 7 -> 9 (reason 14)
NetworkManager: <info>  Marking connection 'unicom' invalid.
NetworkManager: <info>  Activation (eth0) failed.
Comment 1 landrew 2009-11-03 23:46:19 EST
My platform is dell 640m. NetworkManager works well with DSL in fedora 10/11
Comment 3 Nick Bebout 2009-11-04 16:34:28 EST
Removed fedora group restriction per discussion on IRC #fedora-devel
Comment 4 Dan Williams 2009-11-04 17:46:23 EST
Test builds available here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1788689

Would you mind installing those and seeing if they fix the problem?  If so, we can try to get these into Fedora 12 before it gets released.
Comment 5 Adam Williamson 2009-11-04 17:58:55 EST
jlaska, notting, warren - we need a vote on whether to make this a blocker, impact is on everyone who uses an ADSL/PPPoE connection direct into their PC (i.e. not via a router) to get online, as I understand it. (Maybe all direct PPPoE connections, dcbw can clarify). jlaska has concerns about accepting changes to NM this late that could potentially change the codepath for _all_ connections. Personally I recognize that but I think I lean to accepting this as a blocker as the impact is sufficiently serious. votes?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2009-11-04 18:01:21 EST
on the impact of the change, dcbw says:

<dcbw> adamw: the fix could affect wired 802.1x as well, but the fix ensures the same conditions as pre-patch
<dcbw> adamw: basically it loosens conditions for PPPoE but preserves them for 802.1x

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Bill Nottingham 2009-11-04 18:02:30 EST
Given we have a fix, I'd take this.
Comment 8 Dan Williams 2009-11-04 18:09:59 EST
Actual patch used in the build is:

http://cvs.fedoraproject.org/viewvc/F-12/NetworkManager/pppoe-auth-fix-82011dff04123d.patch?view=markup
Comment 9 Adam Williamson 2009-11-04 18:43:00 EST
if we get a +1 from jesse or jlaska i think we can put it in...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 James Laska 2009-11-04 19:01:43 EST
+1

Spoke (okay typed) with Dan on IRC.  I'm hesitant to open up NetworkManager at this point if the patches affect common wire{d,less} code paths.  However, Dan feels confident with the patch and feels 95% certain the changes are specific to pppoe code paths (and not common code).  

I'm comfortable taking the patch.  Once we have confirmation of the fix, I gather we'll do the tagging?  Our fallback should regressions surface during RC validation will be to revert the patch and document the issue.
Comment 11 Adam Williamson 2009-11-04 19:51:10 EST
in that case, adding to the blocker list.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 landrew 2009-11-04 21:42:56 EST
great, it works!

I tried it three times, all succeded.

thanks.
Comment 13 Jesse Keating 2009-11-04 22:11:30 EST
Tagged for the release.
Comment 14 James Laska 2009-11-04 22:20:43 EST
(In reply to comment #12)
> great, it works!
> 
> I tried it three times, all succeded.

Thanks for the quick turnaround on testing!
Comment 15 Dan Williams 2009-11-06 20:20:28 EST
*** Bug 532046 has been marked as a duplicate of this bug. ***