Bug 532972

Summary: Xvnc server does not support IPv6
Product: [Fedora] Fedora Reporter: Tore Anderson <tore>
Component: tigervncAssignee: Jan Grulich <jgrulich>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 22CC: nmavrogi, ovasik
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-05-16 07:24:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 195271    

Description Tore Anderson 2009-11-04 09:49:17 EST
Description of problem:

The Xvnc (possibly x0vncserver as well, haven't tested) is incapable of accepting incoming connections over IPv6.  (The vncviewer tool, on the other hand, appears to support IPv6, at least it attempts to connect to remote servers over IPv6, but without a server implementation I cannot verify that it actually works.)

Version-Release number of selected component (if applicable):

tigervnc-server-1.0.0-1.fc12.i686
Fedora 12 Beta

How reproducible:

100%

Steps to Reproduce:
1. Start an Xvnc server on a machine with IPv6
2. Attempt to connect to it using it's IPv6 address
3.
  
Actual results:

vncviewer fails with "Connection refused"

Expected results:

vncviewer succeeds in connecting to the VNC server, using IPv6

Additional info:

The problem is obvious when looking at common/network/TcpSocket.cxx lines 355-356:

  if ((fd = socket(AF_INET, SOCK_STREAM, 0)) < 0)
    throw SocketException("unable to create listening socket", errorNumber);

This hardcodes the use of an AF_INET (ie. IPv4) listening socket.

There's a bug report (with patches) in Debian's BTS, not sure if those will work with the TigerVNC code base though:  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550789

Tore
Comment 1 Tore Anderson 2009-11-09 07:21:05 EST
In my original report I wrote:

The vncviewer tool, on the other hand, appears to support IPv6, at least it attempts to connect to remote servers over IPv6, but without a server implementation I cannot verify that it actually works.

I've verified that this works correctly now.  When using a SSH tunnel to connect to the remote server (e.g. "ssh -L 5900:127.0.0.1:5900 remote-server"), I can successfully connect to ::1 on the local host, and the remote desktop shows up just fine.  So the VNC protocol itself works beautifully over IPv6, only thing that's missing is for Xvnc to be able to open a listening IPv6 socket.

Tore
Comment 2 Adam Tkac 2009-11-09 08:10:03 EST
Missing IPv6 support on server side is known problem. Upstream report: https://sourceforge.net/tracker/?func=detail&aid=2682797&group_id=254363&atid=1126849
Comment 3 Bug Zapper 2009-11-16 10:04:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Tkac 2010-08-18 07:33:54 EDT
Moving to rawhide, this issue won't be addressed in Fedora 12/13/14.
Comment 6 Fedora Admin XMLRPC Client 2013-05-13 10:53:29 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Tim Waugh 2015-04-28 06:21:01 EDT
Fixed upstream:
  https://github.com/TigerVNC/tigervnc/pull/150
Comment 8 Nikos Mavrogiannopoulos 2015-05-19 05:12:04 EDT
Will that be included in f22 or f23?
Comment 9 Tim Waugh 2015-05-19 06:12:45 EDT
There hasn't yet been an upstream release with this change included, but when 1.4.4 is out I'm sure we'll have a Fedora update soon after.
Comment 10 Nikos Mavrogiannopoulos 2015-07-15 03:24:50 EDT
There is already a release by upstream with IPv6.
https://github.com/TigerVNC/tigervnc/releases/tag/v1.5.0
Comment 11 Fedora Admin XMLRPC Client 2015-08-20 04:44:32 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Mike McCune 2016-03-28 18:46:32 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions