Bug 533524

Summary: BCM57780 fails to start under tg3 module
Product: [Fedora] Fedora Reporter: Brian G. Anderson <bikehead>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: dougsland, gansalmon, itamar, kernel-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-09 13:00:11 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brian G. Anderson 2009-11-06 20:04:33 EST
Description of problem:
I have a Broadcom Corporation Netlink BCM57780 Gigabit Ethernet PCIe (rev 01) card in a Dell T1500.  The tg3 module fails to start the eth0 interface with this message:
tg3.c:v3.99 (April 20, 2009)
tg3 0000:02:00.0: PCI INTA -> GSI 16 (level, low) -> IRQ 16
tg3 0000:02:00.0: setting latency timer to 64
tg3 0000:02:00.0: PME# disabled
tg3 mdio bus: probed
eth%d: No PHY devices
tg3: Problem fetching invariants of chip, aborting.
tg3 0000:02:00.0: PCI INT A disabled

Version-Release number of selected component (if applicable):
2.6.31.1-56

How reproducible:
everytime

Steps to Reproduce:
1.boot kernel
2.
3.
  
Actual results:
tg3 fails to create eth0

Expected results:
an eth0 at boot so I can have a network

Additional info:
Comment 1 Brian G. Anderson 2009-11-07 08:14:14 EST
I should also add that this was a fresh beta install.
Comment 2 Brian G. Anderson 2009-11-07 20:47:59 EST
I tried installing FC11 fresh and it failed with the same error.
Comment 3 Brian G. Anderson 2009-11-07 21:27:30 EST
Oh I see this is already reported against the FC11 as bug 525966

https://bugzilla.redhat.com/show_bug.cgi?id=525966
Comment 4 Chuck Ebbert 2009-11-09 13:00:11 EST

*** This bug has been marked as a duplicate of bug 525966 ***