Bug 535936 (RHQ-339)

Summary: Unintuitive controls on Metric Templates page
Product: [Other] RHQ Project Reporter: Jeff Weiss <jweiss>
Component: Core UIAssignee: RHQ Project Maintainer <rhq-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Mike Foley <mfoley>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: asantos, cwelton, dajohnso, jshaughn
Target Milestone: ---Keywords: FutureFeature, Improvement
Target Release: ---   
Hardware: All   
OS: All   
URL: http://jira.rhq-project.org/browse/RHQ-339
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
all
Last Closed: 2014-05-12 15:28:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Weiss 2008-04-18 11:48:00 EDT
Under metric templates, when you want to enable a metric, you select the checkbox.  Then you look at the bottom of the page.   There's a disable collection button but no "enable".  just a blue "play" arrow.  It should be more consistent.  A play arrow doesn't really make sense there.
Comment 1 Joseph Marques 2008-06-23 16:47:29 EDT
this is a cosmetic issue, but also one that wouldn't take more than an hour to fix and make clearer.  i'm going to target for the 1.1 time frame, to see if it gets picked off as low-hanging fruit by anyone.
Comment 2 Greg Hinkle 2008-07-29 21:08:57 EDT
Those play arrows are in several places. I've always hated them. Since it doesn't seem we'll get usability help any time soon let's just fix them one by one. Replace the play button with an Enable button. 
Comment 3 Heiko W. Rupp 2008-09-14 16:04:19 EDT
This should be  a "set and enable" button.
A simple "enable" where the user only has to choose the metrics, without giving an interval is plain missing.
Comment 4 Greg Hinkle 2008-10-02 23:43:48 EDT
next release
Comment 5 Red Hat Bugzilla 2009-11-10 16:07:19 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-339
Comment 6 Corey Welton 2010-08-10 14:17:35 EDT
Moving this to ON_QA -- test it, and if it is not fixed, move it back to an assigned state.
Comment 7 Jeff Weiss 2010-08-10 14:39:58 EDT
Still an issue in RHQ master branch.  This UI page hasn't been GWT-ized yet.