Bug 536040 (RHQ-432)

Summary: scheduled group operations are not listed on the Resource Operation Schedules
Product: [Other] RHQ Project Reporter: Jessica Sant <jsant>
Component: OperationsAssignee: RHQ Project Maintainer <rhq-maint>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: urgent    
Version: 1.0CC: asantos, ccrouch, cwelton, hrupp
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
URL: http://jira.rhq-project.org/browse/RHQ-432
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
rhqGA_RC10 / jonGA_RC6
Last Closed: 2013-09-04 04:48:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jessica Sant 2008-05-02 21:23:00 EDT
I scheduled a resource group operation for 2 JBoss AS servers. 

I can view the scheduled operations in the Group's operation tab.
However, I can NOT view the scheduled operations in an individual Resource's (who is part of the group) operation tab.

I would expect that I can -- particularly because I can see an Alert Template-defined alert in an individual resource
Comment 1 Joseph Marques 2008-06-05 22:38:07 EDT
templates are slightly different than groups.  it was always the intention to allow people to change the alert definitions that create created from alert templates.  however, i think it would be quite a bit more dangerous to allow the same for group operations.

perhaps a nice middle ground here would be to show a ready-only copy of the schedule as defined by the group.  
Comment 2 Red Hat Bugzilla 2009-11-10 16:09:10 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-432
Comment 3 Joseph Marques 2010-08-10 17:58:31 EDT
Some background:

When you look at schedule operations for a resource, you are only seeing operations that have been explicitly scheduled on that resource and are persisted against that resource in the database.  In other words, you won't see operations that were scheduled at the group level.

Possible fixes:

1) When creating a group-wise operation schedules, also create the resource schedule children.

* the API for retrieving the operation schedules at the resource-level doesn't need to be updated, because the schedules persisted against that resource will come from both the explicit resource-level as well as the trickled-down group-level
* the group-wise API implementation now requires managing the children schedules.  so, again, during group schedule creation, the children schedules need to be created.  during group schedule deletion, the children schedules need to be deleted.  above and beyond that, we have to worry about whether we should allow a user to modify a resource schedule that was created via group-schedule trickle-down, as well as any finer points introduced by the allowance of such.
* note: the group operation would no longer "control" the resource-level operations because the schedules would be independent.  so additional logic would be added to reinforce this relationship, so that serialized semantics (execute operations in the order the resources were specified) could still be upheld.

2) When viewing the list of resource-wise operation schedules, compute the effective list of schedules on-the-fly.

* the group-wise API implementation wouldn't have to change at all
* the resource-wise API would have to be modified to, at the time of the request, look at all groups that resource is currently in and add to the result set any operation schedules also at the group-level.
* since these "effective" scheduled operations don't actually exist at the resource-level yet, editing them is not possible, but users might think it's plausible (thus, this might be a usability issue)
* note: if the resource is in a large number of groups, this on-the-fly calculation could be a performance penalty.  also, because these "ghost" schedules (the ones trickled down from the group) are not actually persisted, pagination would be an increasingly complex thing to manage here (which could be mitigated if we changed the API to **always** return all schedules instead of a paginated set)
Comment 4 Heiko W. Rupp 2013-09-04 04:48:45 EDT
Closing as outdated