Bug 537420

Summary: Initscript for openvpn daemon is not LSB compliant
Product: [Fedora] Fedora Reporter: Zbysek MRAZ <zmraz>
Component: openvpnAssignee: Steven Pritchard <steve>
Status: CLOSED DUPLICATE QA Contact: Zbysek MRAZ <zmraz>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: ebenes, gwync, steve
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 537421 (view as bug list) Environment:
Last Closed: 2009-12-17 18:53:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 537421    

Description Zbysek MRAZ 2009-11-13 15:23:58 UTC
Description of problem:
According to https://fedoraproject.org/wiki/FCNewInit/Initscripts "service XYZ
status" should return 3 when program is not running.

openvpn returns 1 when daemon is not running

Version-Release number of selected component (if applicable):
openvpn-2.1-0.37.rc20.fc12.i686

How reproducible:
always

Steps to Reproduce:
1. Make sure that service is stopped (service kadmin stop)
2. service kadmin status ; echo $?

Actual results:
[root@localhost ~]# service openvpn status ; echo $?
openvpn: service not started
1

Expected results:
[root@localhost ~]# service openvpn status ; echo $?
openvpn: service not started
3

Comment 1 Bug Zapper 2009-11-16 15:31:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Gwyn Ciesla 2009-12-17 18:53:33 UTC

*** This bug has been marked as a duplicate of bug 3929 ***