Bug 5381

Summary: gnome-terminal sometimes core dumps on SMP box
Product: [Retired] Red Hat Linux Reporter: Stephen John Smoogen <smooge>
Component: gnome-coreAssignee: Elliot Lee <sopwith>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-17 21:47:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Stephen John Smoogen 1999-09-26 20:40:16 UTC
[root@test81 /root]# rpm -qf /usr/bin/gnome-terminal

Core was generated by `gnome-terminal --sm-config-prefix
/gnome-terminal-BCKBH5/ --sm-client-id 11cfaf'.
Program terminated with signal 6, Aborted.

(gdb) bt
#0  0x403f34e1 in __kill () from /lib/libc.so.6
#1  0x403f3156 in raise (sig=6) at
#2  0x403f4868 in abort () at ../sysdeps/generic/abort.c:88
#3  0x40081df6 in gnome_segv_handle () from
#4  0x403f3408 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
#5  0x403c48d8 in vt_draw_selection () from
#6  0x403ca579 in zvt_term_button_release () from
#7  0x401c1719 in gtk_marshal_BOOL__POINTER () from
#8  0x401ee45b in gtk_signal_real_emit () from
#9  0x401ec575 in gtk_signal_emit () from
#10 0x4022177c in gtk_widget_event () from
#11 0x401c1672 in gtk_propagate_event () from
#12 0x401c08ca in gtk_main_do_event () from
#13 0x4026b00b in gdk_event_dispatch () from
#14 0x403a8be6 in g_main_dispatch () from
#15 0x403a91a1 in g_main_iterate () from
#16 0x403a9341 in g_main_run () from
#17 0x401c0209 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#18 0x8051ba4 in new_terminal ()
#19 0x8051bc6 in main ()
#20 0x403ed1eb in __libc_start_main (main=0x8051bb0 <main>,
    argv=0xbffffb94, init=0x804b64c <_init>, fini=0x8051bfc
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffb8c)
    at ../sysdeps/generic/libc-start.c:90

How I triggered it:
Opened a gnome-terminal
 rpm -Va &> somefile
Opened another gnome terminal

Had default window settings so focus did not transfer when I
began typing in other window... did a couple of ^U to try
and clear text. Worked in other terminal for a short while
and noticed nothing was happening in first terminal.
Switched focus to first terminal and tried a ^S^Q combo to
see if I had locked up earlier. Bingo gnome reports that
gnome-terminal had locked up.

Comment 1 Elliot Lee 1999-10-29 14:49:59 UTC
Can you provide some instructions for reproducing this? I can't seem
to do it using the "How I triggered it" ones.

Comment 2 Elliot Lee 1999-11-17 21:47:59 UTC
No instructions given on reproducing, so am closing.