This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 538578

Summary: X refuses to start after F11 -> F12 upgrade
Product: [Fedora] Fedora Reporter: Răzvan Sandu <razvan.sandu>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 12CC: airlied, ajax, awilliam, bloch, bskeggs, campbecg, marius.stracna, oli, ulrich
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=85741&forum=12&post_id=383045
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2010-01-26 02:50:09 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Răzvan Sandu 2009-11-18 15:49:26 EST
Description of problem:

Hello,

On some systems that were upgraded from F11 to F12 (via official DVD), X refuses to start after upgrade (systems are set to run into runlevel 3 by default and "startx" command does not work).

As I see at

http://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=85741&forum=12&post_id=383045

the same error message occured before, to other testers.


Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-17.20091105gite1c2efd.fc12.x86_64

How reproducible:
In some cases.

Steps to Reproduce:
1. Install F11
2. Set F11 to boot in runlevel 3
3. Use "startx" command to verify that X interface is starting normally
3. Upgrade F11 to F12 via official DVD
  
Actual results:
X interface won't start after upgrade.

Expected results:
X interface should start normally.


Additional info:

Putting the system in default runlevel 5 only leads to a blinking line on screen, instead of graphical desktop.


Hardware profile, obtained via smolt, is here:
http://www.smolts.org/client/show/pub_2484df5e-0895-4fe9-9898-263062f30efc


The output os lspci -vvv is (regarding graphics card):

04:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2) (prog-if 00 [VGA controller])
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 16 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at df000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at de000000 (64-bit, non-prefetchable) [size=16M]
	Expansion ROM at ddfe0000 [disabled] [size=128K]
	Capabilities: [60] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <4us
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <1us, L1 <4us
			ClockPM- Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk-
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [128] Power Budgeting <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau, nvidiafb



The file /var/log/Xorg.0.log says:


[root@fileserver2 ~]# cat /var/log/Xorg.0.log

X.Org X Server 1.7.1
Release Date: 2009-10-23
X Protocol Version 11, Revision 0
Build Operating System:  2.6.18-164.2.1.el5 
Current Operating System: Linux fileserver2.mobexpert.ro 2.6.31.5-127.fc12.x86_64 #1 SMP Sat Nov 7 21:11:14 EST 2009 x86_64
Kernel command line: ro root=UUID=44d54cf4-a666-43ca-a1f5-40aba0a415b8 rhgb quiet SYSFONT=Lat2-Terminus16 LANG=ro_RO.UTF-8 KEYTABLE=ro
Build Date: 05 November 2009  07:43:10PM
Build ID: xorg-x11-server 1.7.1-7.fc12 
Current version of pixman: 0.16.2
	Before reporting problems, check http://bodhi.fedoraproject.org/
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 18 22:18:15 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "single head configuration"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Videocard0"
(==) No monitor specified for screen "Screen0".
	Using a default monitor configuration.
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
	catalogue:/etc/X11/fontpath.d,
	built-ins
(==) ModulePath set to "/usr/lib64/xorg/modules"
(II) Cannot locate a core pointer device.
(II) The server relies on HAL to provide the list of input devices.
	If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(II) Loader magic: 0x7c8560
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 6.0
	X.Org XInput driver : 7.0
	X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:4:0:0) 10de:0141:0000:02a1 nVidia Corporation NV43 [GeForce 6600] rev 162, Mem @ 0xdf000000/16777216, 0xe0000000/268435456, 0xde000000/16777216, BIOS @ 0x????????/131072
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.7.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.7.1, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
	compiled for 1.7.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.7.1, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.7.1, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.7.1, module version = 1.1.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nv"
(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
	compiled for 1.7.0, module version = 2.1.15
	Module class: X.Org Video Driver
	ABI class: X.Org Video Driver, version 6.0
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
	Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
	Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
	GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
	GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
	Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
	GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
	GeForce4 420 Go 32M, GeForce4 460 Go, Quadro4 550 XGL,
	GeForce4 440 Go 64M, Quadro NVS, Quadro4 500 GoGL,
	GeForce4 410 Go 16M, GeForce4 MX 440 with AGP8X,
	GeForce4 MX 440SE with AGP8X, GeForce4 MX 420 with AGP8X,
	GeForce4 MX 4000, GeForce4 448 Go, GeForce4 488 Go, Quadro4 580 XGL,
	Quadro4 NVS 280 SD, Quadro4 380 XGL, Quadro NVS 50 PCI,
	GeForce4 448 Go, GeForce4 MX Integrated GPU, GeForce3,
	GeForce3 Ti 200, GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600,
	GeForce4 Ti 4400, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
	Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
	GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
	Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
	GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
	GeForce FX 5600 Ultra, GeForce FX 5600, GeForce FX 5600XT,
	GeForce FX Go5600, GeForce FX Go5650, Quadro FX Go700,
	GeForce FX 5200, GeForce FX 5200 Ultra, GeForce FX 5200,
	GeForce FX 5200LE, GeForce FX Go5200, GeForce FX Go5250,
	GeForce FX 5500, GeForce FX 5100, GeForce FX Go5200 32M/64M,
	Quadro NVS 55/280 PCI, Quadro FX 500/600 PCI,
	GeForce FX Go53xx Series, GeForce FX Go5100, GeForce FX 5900 Ultra,
	GeForce FX 5900, GeForce FX 5900XT, GeForce FX 5950 Ultra,
	GeForce FX 5900ZT, Quadro FX 3000, Quadro FX 700,
	GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
	GeForce FX 5700VE, GeForce FX Go5700, GeForce FX Go5700,
	Quadro FX Go1000, Quadro FX 1100, GeForce 6800 Ultra, GeForce 6800,
	GeForce 6800 LE, GeForce 6800 XE, GeForce 6800 XT, GeForce 6800 GT,
	GeForce 6800 GT, GeForce 6800 GS, GeForce 6800 XT, Quadro FX 4000,
	GeForce 6800 GS, GeForce 6800, GeForce 6800 LE, GeForce 6800 XT,
	GeForce Go 6800, GeForce Go 6800 Ultra, Quadro FX Go1400,
	Quadro FX 3450/4000 SDI, Quadro FX 1400, GeForce 6600 GT,
	GeForce 6600, GeForce 6600 LE, GeForce 6600 VE, GeForce Go 6600,
	GeForce 6610 XL, GeForce Go 6600 TE/6200 TE, GeForce 6700 XL,
	GeForce Go 6600, GeForce Go 6600 GT, Quadro NVS 440, Quadro FX 550,
	Quadro FX 550, Quadro FX 540, GeForce 6200, GeForce 6500,
	GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
	GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
	GeForce Go 6200, GeForce Go 6400, GeForce 6250, GeForce 7100 GS,
	GeForce 6800, GeForce 6800 LE, GeForce 6800 GT, GeForce 6800 XT,
	GeForce 6200, GeForce 6200 A-LE, GeForce 7800 GTX, GeForce 7800 GTX,
	GeForce 7800 GT, GeForce 7800 GS, GeForce 7800 SLI, GeForce Go 7800,
	GeForce Go 7800 GTX, Quadro FX 4500, GeForce 7350 LE,
	GeForce 7300 LE, GeForce 7300 SE, GeForce Go 7200, GeForce Go 7300,
	GeForce Go 7400, GeForce Go 7400 GS, Quadro NVS 110M,
	Quadro NVS 120M, Quadro FX 350M, GeForce 7500 LE, Quadro FX 350,
	GeForce 7300 GS, GeForce 7650 GS, GeForce 7600 GT, GeForce 7600 GS,
	GeForce 7300 GT, GeForce 7600 LE, GeForce 7300 GT, GeForce Go 7700,
	GeForce Go 7600, GeForce Go 7600 GT, Quadro NVS 300M,
	GeForce Go 7900 SE, Quadro FX 550M, Quadro FX 560, GeForce 7900 GTX,
	GeForce 7900 GT, GeForce 7900 GS, GeForce 7950 GX2, GeForce 7950 GX2,
	GeForce 7950 GT, GeForce Go 7950 GTX, GeForce Go 7900 GS,
	GeForce Go 7900 GTX, Quadro FX 2500M, Quadro FX 1500M,
	Quadro FX 5500, Quadro FX 3500, Quadro FX 1500, Quadro FX 4500 X2,
	GeForce 6150, GeForce 6150 LE, GeForce 6100, GeForce Go 6150,
	Quadro NVS 210S / NVIDIA GeForce 6150LE, GeForce Go 6100,
	GeForce 6150SE, GeForce 6100 nForce 405, GeForce 6100 nForce 400,
	GeForce 6100 nForce 420, GeForce 7025, GeForce 7050,
	GeForce 8800 GTX, GeForce 8800 GTS, GeForce 8800 Ultra,
	Quadro FX 5600, Quadro FX 4600, GeForce 8600 GTS, GeForce 8600 GT,
	GeForce 8600 GT, GeForce 8600 GS, GeForce 8400 GS, GeForce 9500M GS,
	GeForce 8600M GT, GeForce 9650M GS, GeForce 8700M GT, Quadro FX 370,
	Quadro NVS 320M, Quadro FX 570M, Quadro FX 1600M, Quadro FX 570,
	Quadro FX 1700, GeForce 8400 SE, GeForce 8500 GT, GeForce 8400 GS,
	GeForce 8300 GS, GeForce 8400 GS, GeForce 8600M GS, GeForce 8400M GT,
	GeForce 8400M GS, GeForce 8400M G, Quadro NVS 140M, Quadro NVS 130M,
	Quadro NVS 135M, GeForce 9400 GT, Quadro FX 360M, GeForce 9300M G,
	Quadro NVS 290, GeForce GTX 295, GeForce GTX 280, GeForce GTX 260,
	GeForce GTX 285, Quadro CX, Quadro FX 5800, Quadro FX 4800,
	Quadro FX 3800, GeForce 8800 GTS 512, GeForce 9800 GT,
	GeForce 8800 GT, GeForce 9800 GX2, GeForce 9800 GT, GeForce 8800 GS,
	GeForce 9800M GTX, GeForce 8800M GTS, GeForce 9800M GT,
	GeForce 8800M GTX, GeForce 8800 GS, GeForce 9600 GSO,
	GeForce 8800 GT, GeForce 9800 GTX, GeForce 9800 GTX+,
	GeForce 9800 GT, GeForce GTS 250, GeForce 9800M GTX, Quadro FX 3700,
	Quadro FX 3600M, Quadro FX 3700M, GeForce 9600 GT, GeForce 9600 GS,
	GeForce 9600 GSO 512, GeForce GT 130, GeForce GT 140,
	GeForce 9800M GTS, GeForce 9700M GTS, GeForce 9800M GS,
	GeForce 9800M GTS, Quadro FX 1800, Quadro FX 2700M, GeForce 9500 GT,
	GeForce 9400 GT, GeForce 9500 GT, GeForce GT 120, GeForce 9600M GT,
	GeForce 9600M GS, GeForce 9600M GT, GeForce 9700M GT,
	GeForce 9500M G, GeForce 9650M GT, GeForce 9500 GT, Quadro FX 380,
	Quadro FX 580, Quadro FX 770M, GeForce 9300 GE, GeForce 9300 GS,
	GeForce 8400 GS, GeForce 9300M GS, GeForce G100, GeForce 9200M GS,
	GeForce 9300M GS, Quadro NVS 150M, Quadro NVS 160M, Quadro NVS 420,
	Quadro FX 370 LP, Quadro NVS 450, Quadro NVS 295
(II) Primary Device is: PCI 04@00:00:0
The PCI device has a kernel module claiming it.
This driver cannot operate until it has been unloaded
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
	 at http://bodhi.fedoraproject.org/
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
Comment 1 Ben Skeggs 2009-11-18 18:28:31 EST
Remove /etc/X11/xorg.conf, something's configured your system to use the "nv" driver, which can't work with nouveau kernel modesetting enabled.  Not a nouveau bug, but if it was something during the upgrade that reconfigured your xorg.conf, it could belong elsewhere.
Comment 2 Adam Williamson 2009-11-25 16:10:30 EST
"(II) Primary Device is: PCI 04@00:00:0
The PCI device has a kernel module claiming it."

Ben, that rather looks to me like he had the NVIDIA proprietary driver enabled, and didn't have the RPM Fusion testing repos enabled during his upgrade so didn't get the updated NVIDIA driver for F12 installed.

Reporter, can you say whether this is the case? Did you have the NVIDIA proprietary driver installed on your F11 systems? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Răzvan Sandu 2009-11-25 17:13:52 EST
Hello,

@Adam
No, for the X part, I've only installed Fedora official packages (from official repositories). I use other components from rpmfusion, such as vlc.

@Ben
Thanks for your advice, I've solved the problem by deleting /etc/X11/xorg.conf completely.

Please let me know if I may perform other tests, in order to help - I'll gladly do it...


Best regards,
Răzvan
Comment 4 Ben Skeggs 2009-11-25 17:53:28 EST
Adam: I added code in nv/vesa to guard against starting them while nouveau KMS was in control of the card, and that message is from there.  It's much better than having the system die horribly when two very different drivers are fighting for control of the hw :)

The problem is for people with "nv" in xorg.conf, unless they boot with "nomodeset", or change xorg.conf to nouveau, they'll hit this issue.  But, I don't see we can do better than we currently do.

Răzvan: Glad to hear it works :)  Are you happy to close this?
Comment 5 Adam Williamson 2009-11-25 21:27:49 EST
ben: ah, gotcha. right, I don't think we can safely mung people's xorg.conf file on upgrade, it doesn't seem like a right thing to do.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Chris Campbell 2010-01-23 15:16:23 EST
Reporter, per Comment 4, is this issue resolved to your satisfaction? (May we close it?)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Răzvan Sandu 2010-01-24 15:07:04 EST
@Chris

Hello,

Deleting /etc/X11/xorg.conf works for me, because I only use stock, automatically-configured xorg.conf files. *For me* , this bug may be closed.

However, people with heavily hand-crafted configuration files will probably find unacceptable to delete them and redo work from scratch. Please ask one of those people before taking a final decision.

Many thanks,
Răzvan
Comment 8 Adam Williamson 2010-01-26 02:50:09 EST
There's really nothing safe we can do about this. We can't go arbitrarily changing the driver defined in the configuration file.